Bug 492289

Summary: Nouveau driver fail on X initialization - QA Test Day
Product: [Fedora] Fedora Reporter: Marco Somoza <macsweb>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 11CC: airlied, ajax, awilliam, bskeggs
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-17 00:53:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
Xorg.0.log after xstart
The only file in /var/run/nv*.rom is nv84_0402.rom
File from test on day 04/23/2009
dmesg command output before startx
dmesg command output after startx none

Description Marco Somoza 2009-03-26 11:09:59 UTC
The X initialization fails with the Nouveau driver.

I just see lines in text mode with the message:


Hardware profile:

Comment 1 Adam Williamson 2009-03-27 20:41:34 UTC
Can you do anything at that point?

Can you boot to runlevel 3 (instructions in the X restart test case) and run 'startx' and see if that gets any more useful information?

Can you try the KMS test case and see if it works in that situation? One guy found it worked *with* KMS but not without on his system - which is unusual, but it'd be worth testing here.


Fedora Bugzappers volunteer triage team

Comment 2 Marco Somoza 2009-03-28 01:54:08 UTC
I've done both tests and the result is:

Test 1-runlevel 3 and run startx:

I get the following message:

NOUVEAU(0): 1411 : no valid modes
screens(s) found, but none have a usable configuration
Fatal server error: no screens found.

Test 2-KMS test

It works! and detects my monitor LG 1680x1050.

If I can help please just ask, and thank you for the good work.


Comment 3 Ben Skeggs 2009-03-29 22:31:43 UTC
Hey there!  Can I get your /var/log/Xorg.0.log from after starting X has failed without kms?  I have an idea what's wrong here, but want to confirm.


Comment 4 Marco Somoza 2009-03-30 01:10:28 UTC
Created attachment 337188 [details]
Xorg.0.log after xstart

The xorg.0.log file after xstart command.

Comment 5 Marco Somoza 2009-03-30 01:13:11 UTC
I attached the xorg.0.log as asked. ok?

Best regards

Comment 6 Adam Williamson 2009-03-30 19:40:05 UTC
Thanks, Marco.

Fedora Bugzappers volunteer triage team

Comment 7 Ben Skeggs 2009-03-31 01:16:17 UTC
Thanks Marco.  Could you also attach /var/run/nv*.rom after you've tried to run nouveau?

Comment 8 Ben Skeggs 2009-04-03 04:25:42 UTC
I took a bit of a guess at what's wrong here, but can't be certain as I never got a VBIOS image to look at...  Do things work better with xorg-x11-drv-nouveau-0.0.12-21.20090403git11be9a9.fc11 ?

Comment 9 Adam Williamson 2009-04-17 21:20:51 UTC
Any update, Marco?

Fedora Bugzappers volunteer triage team

Comment 10 Marco Somoza 2009-04-20 02:58:13 UTC
First of all sorry for the delay!
I had to move to a new house. :)

I have tested F11 Beta and:

1-Normal boot fails and the box freeze.

2-booting with nouveau.modset=1 works AND I will attach the file


Comment 11 Marco Somoza 2009-04-20 03:00:55 UTC
Created attachment 340280 [details]
The only file in /var/run/nv*.rom is nv84_0402.rom

Comment 12 Ben Skeggs 2009-04-20 03:16:26 UTC
What version of xorg-x11-drv-nouveau did you test with?  The fixes I was thinking of are in -21.


Comment 13 Marco Somoza 2009-04-21 19:49:08 UTC
I tested with F11 Live Beta x86_64.

I can test other version, just guide me, please. :)

Thank you

Comment 14 Adam Williamson 2009-04-21 20:27:47 UTC
we need to know what version of nouveau is on there - we don't know that offhand. 'rpm -q xorg-x11-drv-nouveau' from that live CD should tell you.

Fedora Bugzappers volunteer triage team

Comment 15 Marco Somoza 2009-04-21 22:01:40 UTC
The Output for command is:



Comment 16 Adam Williamson 2009-04-21 22:28:00 UTC
ah - that one's not new enough to tell :( could you possibly try with the fedora 11 snapshot live CD? you can find it here: http://torrent.fedoraproject.org/ thanks!

Fedora Bugzappers volunteer triage team

Comment 17 Marco Somoza 2009-04-23 22:28:01 UTC
well, I did a new test with fedora 11 live snapshot CD x86_64, date 04/10/09.

rpm -q xorg-x11-drv-nouveau outputs:


unfortunately same error.

I'll attach the Xorg.0.log


Comment 18 Marco Somoza 2009-04-23 22:29:52 UTC
Created attachment 341031 [details]
File from test on day 04/23/2009

File from test on day 04/23/2009

Comment 19 Ben Skeggs 2009-05-04 03:34:31 UTC
Are you able to do a kms boot into runlevel 3 with nouveau.debug=1 on the commandline, and attach the output of "dmesg" for me?  Thanks!

Comment 20 Marco Somoza 2009-05-06 04:08:10 UTC
Yes, I did the test and that's what happened:

I booted the last F11 preview with:

1-   kernel parameters 3 and nouveau.debug=1

2-   logged as root

3-   dmesg > dmesg1.txt

4-   startx (IT WORKED AND gnome performed well)

5-   dmesg > dmesg2.txt

If you need any further information, just ask!

Thank you

Comment 21 Marco Somoza 2009-05-06 04:12:12 UTC
Created attachment 342590 [details]
dmesg command output before startx

Comment 22 Marco Somoza 2009-05-06 04:12:51 UTC
Created attachment 342591 [details]
dmesg command output after startx

Comment 23 Bug Zapper 2009-06-09 12:39:04 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:

Comment 24 Marco Somoza 2009-06-13 15:47:02 UTC
Well I've tested with the final fedora 11 live CD and it works great!

Comment 25 Adam Williamson 2009-06-17 00:53:56 UTC
Great, thanks for the report! Closing the bug, then.

Fedora Bugzappers volunteer triage team