Bug 492698

Summary: kernel kills pulseaudio
Product: [Fedora] Fedora Reporter: Espen Stefansen <libbe>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: kernel-maint, lpoetter, mads, quintela
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-03-30 18:12:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
pulseaudio-log none

Description Espen Stefansen 2009-03-28 09:56:21 EDT
Created attachment 337105 [details]
pulseaudio-log

Description of problem:
Not sure if this is a kernel, alsa or a pulseaudio problem. Feel free to reassign.

I tried in the latest kernel from koji, because it contained alsa-rewrite-hw_ptr-updaters.patch to fix some pulseaudio errors. Playing sound on my computer doesn't work, because the sound is always crackling. 

After updating, pulseaudio crashes within short time, usually within minutes, with the following in messages:
Mar 28 14:28:20 platon pulseaudio[3040]: alsa-sink.c: Increasing wakeup watermark to 60,00 ms
Mar 28 14:31:35 platon pulseaudio[3040]: alsa-sink.c: Increasing wakeup watermark to 70,00 ms
Mar 28 14:31:35 platon pulseaudio[3040]: alsa-sink.c: Increasing wakeup watermark to 80,00 ms
Mar 28 14:31:35 platon pulseaudio[3040]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294952932 bytes (24347805 ms).
Mar 28 14:31:35 platon pulseaudio[3040]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Mar 28 14:31:35 platon pulseaudio[3040]: rtpoll.c: Assertion 'usec <= ((pa_usec_t) 1000000ULL)*60ULL*60ULL' failed at pulsecore/rtpoll.c:548, function pa_rtpoll_set_timer_relative(). Aborting.


kernels that don't work:
kernel-PAE-2.6.29-16.fc11.i686
kernel-PAE-2.6.29-9.fc11.i686

kernels that work:
kernel-2.6.29-0.279.rc8.git6.fc11.i586

lspci:
00:1e.2 Multimedia audio controller: Intel Corporation 82801G (ICH7 Family) AC'97 Audio Controller (rev 01)
	Subsystem: Dell OptiPlex GX620
	Flags: bus master, medium devsel, latency 0, IRQ 23
	I/O ports at ec00 [size=256]
	I/O ports at e8c0 [size=64]
	Memory at febffa00 (32-bit, non-prefetchable) [size=512]
	Memory at febff900 (32-bit, non-prefetchable) [size=256]
	Capabilities: [50] Power Management version 2
	Kernel driver in use: Intel ICH
	Kernel modules: snd-intel8x0


Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-3.test5.fc11.i586
alsa-lib-1.0.19-3.fc11.i586
alsa-plugins-pulseaudio-1.0.18-3.fc11.i586
alsa-utils-1.0.19-4.fc11.i586

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Espen Stefansen 2009-03-30 09:20:27 EDT
I updated to the latest kernel in koji, but pulseaudio still quits after a short time. I got the following in messages:

Mar 30 15:11:57 platon pulseaudio[3022]: alsa-sink.c: Increasing wakeup watermark to 30,00 ms
Mar 30 15:12:53 platon pulseaudio[3022]: alsa-sink.c: Increasing wakeup watermark to 40,00 ms
Mar 30 15:14:55 platon pulseaudio[3022]: alsa-sink.c: Increasing wakeup watermark to 50,00 ms
Mar 30 15:15:15 platon pulseaudio[3022]: alsa-sink.c: Increasing wakeup watermark to 60,00 ms
Mar 30 15:15:15 platon pulseaudio[3022]: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
Mar 30 15:15:15 platon pulseaudio[3022]: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Mar 30 15:15:15 platon pulseaudio[3022]: alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
Mar 30 15:15:16 platon pulseaudio[3022]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294954028 bytes (24347811 ms).
Mar 30 15:15:16 platon pulseaudio[3022]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Mar 30 15:15:16 platon pulseaudio[3022]: rtpoll.c: Assertion 'usec <= ((pa_usec_t) 1000000ULL)*60ULL*60ULL' failed at pulsecore/rtpoll.c:548, function pa_rtpoll_set_timer_relative(). Aborting.

Kernel:
kernel-PAE-2.6.29-21.fc11.i686
Comment 2 Lennart Poettering 2009-03-30 18:12:25 EDT

*** This bug has been marked as a duplicate of bug 485734 ***
Comment 3 Mads Kiilerich 2009-04-11 05:17:31 EDT
Lennart, was that duplication intentional?

This is snd_intel8x0. Bug 485734 is (was?) clearly intel-hda only.

Should it be bug 472339 instead?
Comment 4 Lennart Poettering 2009-04-11 22:16:50 EDT
You are right.

*** This bug has been marked as a duplicate of bug 472339 ***