Bug 492984

Summary: procedure steps are pulled onto next page and leave white space
Product: [Community] Publican Reporter: Darrin Mison <dmison>
Component: publicanAssignee: Ruediger Landmann <rlandman>
Status: CLOSED CURRENTRELEASE QA Contact: Joshua Wulf <jwulf>
Severity: medium Docs Contact:
Priority: low    
Version: 2.0CC: jfearn, lcarlon, mmcallis, publican-list
Target Milestone: ---Keywords: Documentation
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: 1.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-25 23:56:56 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Darrin Mison 2009-03-30 22:26:08 EDT
Description of problem:
Procedure steps that span a "pdf page break" no longer flow from one page to another but instead are pulled down to the start of the next page.  This leaves an area of white space.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create a procedure so one of the steps would span a pdf page break.  The procedure or step doesn't have to be over a page in length, it could occur towards the bottom of a page
2. Build the pdf

Actual results:
The step is pulled down onto the next page leaving a chunk of white space on the previous page.

Expected results:
The text of the step flows from the first page to the next (as it did in 0.44 and earlier)

Additional info:
Caused by the "fix" for bugzilla 492021

I think the reported problem from 492021 is a *content problem*, not a publican problem.  You can't split an image over a page so any series of half page images interspaced with a few lines of text will be a problem.

If we could control this behaviour via an attribute in the step (or procedure) tag that would be useful.  Would also be useful in other tags too I guess
Comment 1 Michael Hideo 2009-06-16 22:11:29 EDT
adding to my list for QA
Comment 3 Jeff Fearn 2009-09-30 20:10:47 EDT
Maybe a better approach would be to override the para template and check for the existence of a figure, and if detected set keep-together for that para.


<xsl:template match="para">
  <fo:block xsl:use-attribute-sets="normal.para.spacing">
    <xsl:if test="descendant::figure">
      <xsl:attribute name="keep-together.within-column">
    <xsl:call-template name="anchor"/>

Untested of course :)

This would mean any para with a figure inside it shouldn't be longer than a page as opposed to any step shouldn't be longer than a page. It would also apply outside of steps.
Comment 4 Jeff Fearn 2009-10-01 20:23:27 EDT
Yo, please supply the SVN location of your source and the PDF pages where you see this problem.
Comment 5 Jeff Fearn 2009-10-02 00:23:56 EDT
This change is checked in the repo, but it's untested. We will need some content to test beta2 on.