Bug 493450

Summary: Updating a release bump resets ghc's internal package list
Product: [Fedora] Fedora Reporter: Bryan O'Sullivan <bos>
Component: ghcAssignee: Jens Petersen <petersen>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 10CC: bos, haskell-devel, loupgaroublond, petersen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-22 02:07:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bryan O'Sullivan 2009-04-01 19:43:04 UTC
Last night, I installed a rawhide version of ghc 6.10.1 in place of the F10 version I had been running. I also had packages such as ghc-X11 installed at the time. When I ran "ghc-pkg list" after the update, the X11 and other such packages were no longer visible.

We need to develop a mechanism to make it possible to make minor updates to ghc without requiring that all devel packages be reinstalled afterwards :-(

Comment 1 Jens Petersen 2009-05-19 07:34:53 UTC
Oh hmm that is bad and "should not happen"...

Comment 2 Jens Petersen 2009-05-19 09:19:35 UTC
Are you sure?  I just tried in i386 f11 downgrading to f10 and back up to f11 ghc
and X11 package appeared for me all along.

package.conf is already marked %config(noreplace) though - I thought that should take care of it.

(We should really move package.conf to /etc like debian, but I think that is another story.)