Bug 493492

Summary: Radeon R200 based system doesn't work correctly with fast user switching
Product: [Fedora] Fedora Reporter: Andreas Thienemann <andreas>
Component: gdmAssignee: jmccann
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: awilliam, cschalle, dtardon, fdc, jmccann, rstrode, xgl-maint
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-21 13:36:42 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
/etc/X11/xorg.conf none

Description Andreas Thienemann 2009-04-01 19:23:37 EDT
Running the "fastuserswitch" test case for Radeon test day
Latest Rawhide can only fastuserswitch once and back when using a R200
based 9100 IGP.


The first switch from the current user to the second user succeeds.
Switching back to the first user works as well.

When switching again to the second user however, the third Xserver running the user chooser is successfully started, but the chooser window is never drawn. The mouse throbber is circling indefinitely and the gdm (?) chooser is stuck only showing the grey background.

Although switching between the three running XServers via CTRL-ALT-F1, F7 or F8 works, the gdm running on F8 is stuck.

Smolt Hardware Profile:

This problem is always repeatable so any requests for system logs can be fulfilled.
Comment 1 David Tardon 2009-04-02 03:51:42 EDT
The same problem here.
Comment 2 David Tardon 2009-04-02 03:52:07 EDT
Created attachment 337732 [details]
Comment 3 David Tardon 2009-04-02 03:52:29 EDT
Created attachment 337733 [details]
Comment 4 David Tardon 2009-04-02 03:52:58 EDT
Created attachment 337734 [details]
Comment 5 David Tardon 2009-04-02 03:54:39 EDT
Graphic card:
ATI Technologies Inc RV380 [Radeon X600] [1002:5b72]

Driver version:
Comment 6 Fran├žois Cami 2009-04-08 17:31:11 EDT
Andreas, David,

If you have rawhide installed, could you try the latest kernel and xorg-x11-drv-ati packages from koji ?
The VT switch should be repaired now. 

Fedora Bugzappers volunteer triage team
Comment 7 Andreas Thienemann 2009-04-13 06:10:12 EDT
Indeed, with the current code this use case works as designed.

[andreas@workstation ~]$ uname -r; rpm -q xorg-x11-drv-ati
[andreas@workstation ~]$
Comment 8 Andreas Thienemann 2009-04-13 06:20:50 EDT
[andreas@workstation ~]$ rpm -q libdrm
[andreas@workstation ~]$
Comment 9 Fran├žois Cami 2009-04-13 06:43:27 EDT
Thank you Andreas, closing.

Fedora Bugzappers volunteer triage team
Comment 10 David Tardon 2009-09-09 10:28:05 EDT
After 6 months the problem is back, with the difference that gdm
shows background, incomplete panel and a gray rectangle.

Version-Release number of selected component (if applicable):

Additional info:
The xorg.conf is needed because of bug 516162.
Comment 11 David Tardon 2009-09-09 10:28:49 EDT
Created attachment 360235 [details]
Comment 12 David Tardon 2009-09-09 10:29:13 EDT
Created attachment 360236 [details]
Comment 13 David Tardon 2009-09-09 10:29:58 EDT
Created attachment 360237 [details]
Comment 14 David Tardon 2009-09-09 10:30:27 EDT
Created attachment 360238 [details]
Comment 15 Dave Airlie 2009-09-13 03:29:16 EDT
I've seen this on Intel and Ben has seen it on nouveau so I think its a gdm issue.

Re assigning to gdm.
Comment 16 David Tardon 2009-09-14 00:54:18 EDT
Version-Release number of selected component (if applicable):
Comment 17 Adam Williamson 2009-10-21 13:36:42 EDT
we've been investigating this in the blocker bug review meeting this morning. it seems there are many reports of this type across multiple types of video hardware. closing all reports as dupes of 512944, which is the earliest report. 512944 will be marked as a release blocker.

Fedora Bugzappers volunteer triage team

*** This bug has been marked as a duplicate of bug 512944 ***