This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 494131

Summary: Traceback with very basic partitionning scheme
Product: [Fedora] Fedora Reporter: Mathieu Bridon <bochecha>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: anaconda-maint-list, pjones, rmaximo, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-06 16:33:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Mathieu Bridon 2009-04-04 17:32:35 EDT
Description of problem:

Fedora 11 beta x86_64 DVD

I wanted to create the following partitionning scheme:
/dev/sda1 /boot ext3   200MB
/dev/sda2 /     ext4 10240MB
/dev/sda3 /home ext4 20480MB
/dev/sda4 extended
/dev/sda5 swap        2048MB

For the first 3 partitions, I checked « make it a primary partition » to be sure that they would be primary partitions (in the past, I had weird experiences with anaconda not respecting the order in which I was creating partitions).

When I tried to confirm the swap partition, I got an « unhandled exception » and anaconda crashed.

I would have attached the report, unfortunately, I couldn't get anaconda to save it, either on my local disk, on a USB key or by SCP (nothing happened when I clicked to confirm in each case).
Comment 1 Chris Lumens 2009-04-06 10:13:25 EDT
Then at least take a picture of the traceback and attach it, or transcribe the first part so we know what the error is.  Otherwise, there's really nothing we can do if we cannot reproduce this.
Comment 2 Mathieu Bridon 2009-04-06 16:18:12 EDT
Sorry, as I can reproduce it 100%, I though it would be enough for you to debug it.

Anyway, here is a transcript of the first part of the trace:
----------
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 1574, in devices
    raise DeviceTreeError("duplicate paths in device tree")
  File "/usr/lib/anaconda/storage/__init.py__", line 294, in disks
    devices = self.devicetree.devices
  File "/usr/lib/anaconda/storage/partitioning.py", line 532, in doPartitioning
    disks = storage.disks
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1019, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1134, in editPartition
    if self.refresh():
  File "/usr/lib/anaconda/iw/partition_gui.py, line 976, in newCB
    self.editPartition(device, isNew=1)
DeviceTreeError: duplicate paths in device tree

Local variables in innermost frame:
...
----------

I took pictures of what follows (not all, it's way too long), so if you need something that comes after, just ask.
Comment 3 Mathieu Bridon 2009-04-06 16:30:51 EDT
Btw, if you want the photos:
http://bochecha.fedorapeople.org/anaconda_error/

(there were too much to attach to the bug report)

Tell me if you don't need them, so that I don't fill up my FedoraPeople.
Comment 4 Chris Lumens 2009-04-06 16:33:25 EDT
That's all I need to tell that it's a duplicate of an existing bug.  Thanks for
filing.  You can remove the pictures if you need space.  Sorry to make you do all that extra work.

*** This bug has been marked as a duplicate of bug 493058 ***