Bug 494459

Summary: udevd-event unable to create db file
Product: [Fedora] Fedora Reporter: Mace Moneta <moneta.mace>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: harald, moneta.mace
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-30 01:34:54 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Mace Moneta 2009-04-06 20:42:19 EDT
Description of problem:

syslog flooded with:

Apr  6 20:34:55 shadow udevd-event[14191]: unable to create db file '/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0': No such file or directory
Apr  6 20:35:24 shadow udevd-event[17391]: unable to create db file '/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0': No such file or directory
Apr  6 20:35:28 shadow udevd-event[17825]: unable to create db file '/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0': No such file or directory
Apr  6 20:35:36 shadow udevd-event[19106]: unable to create db file '/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0': No such file or directory
Apr  6 20:36:37 shadow udevd-event[30699]: unable to create db file '/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0': No such file or directory
Apr  6 20:37:14 shadow udevd-event[5473]: unable to create db file '/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0': No such file or directory
Apr  6 20:37:34 shadow udevd-event[9523]: unable to create db file '/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0': No such file or directory


Version-Release number of selected component (if applicable):

udev-139-4.fc11.x86_64
kernel-2.6.29.1-52.fc11.x86_64
libdrm-2.4.5-4.fc11.x86_64

How reproducible:

Nearly continuously

Steps to Reproduce:
1.Boot
2.
3.
  
Actual results:

Lots of errors logged

Expected results:

Maybe one error, if it's really a problem.

Additional info:
Comment 1 Mace Moneta 2009-04-06 23:35:53 EDT
I checked the logs, and the errors started after this update:

Apr 06 14:27:12 Updated: 1:NetworkManager-glib-0.7.0.100-1.fc11.x86_64
Apr 06 14:27:13 Updated: compiz-0.7.8-18.fc11.x86_64
Apr 06 14:27:13 Updated: setools-libs-3.3.5-8.fc11.x86_64
Apr 06 14:27:15 Updated: kdepimlibs-4.2.2-3.fc11.x86_64
Apr 06 14:27:15 Updated: 2:qemu-common-0.10-6.fc11.x86_64
Apr 06 14:27:16 Updated: kdepimlibs-akonadi-4.2.2-3.fc11.x86_64
Apr 06 14:27:17 Updated: 1:NetworkManager-0.7.0.100-1.fc11.x86_64
Apr 06 14:27:31 Updated: tomboy-0.14.0-2.fc11.x86_64
Apr 06 14:27:32 Updated: libdvbpsi-0.1.6-5.fc11.x86_64
Apr 06 14:27:33 Updated: SDL_mixer-1.2.8-12.fc11.x86_64
Apr 06 14:27:33 Updated: linuxwacom-0.8.2.2-11.fc11.x86_64
Apr 06 14:27:34 Updated: m17n-contrib-1.1.9-3.fc11.noarch
Apr 06 14:27:34 Updated: 1:control-center-filesystem-2.26.0-2.fc11.x86_64
Apr 06 14:27:49 Updated: 1:control-center-2.26.0-2.fc11.x86_64
Apr 06 14:27:49 Updated: 2:qemu-system-ppc-0.10-6.fc11.x86_64
Apr 06 14:27:49 Updated: m17n-contrib-oriya-1.1.9-3.fc11.noarch
Apr 06 14:27:50 Updated: xorg-x11-apps-7.3-8.fc11.x86_64
Apr 06 14:28:04 Updated: compiz-gnome-0.7.8-18.fc11.x86_64
Apr 06 14:28:04 Updated: python-zope-interface-3.5.1-2.fc11.x86_64
Apr 06 14:28:05 Updated: m17n-contrib-hindi-1.1.9-3.fc11.noarch
Apr 06 14:28:05 Updated: m17n-contrib-malayalam-1.1.9-3.fc11.noarch
Apr 06 14:28:05 Updated: m17n-contrib-sinhala-1.1.9-3.fc11.noarch
Apr 06 14:28:06 Updated: 1:NetworkManager-gnome-0.7.0.100-1.fc11.x86_64
Apr 06 14:28:06 Updated: setools-console-3.3.5-8.fc11.x86_64
Apr 06 14:28:07 Updated: m17n-contrib-marathi-1.1.9-3.fc11.noarch
Apr 06 14:28:15 Updated: gnome-user-share-2.26.0-2.fc11.x86_64
Apr 06 14:28:15 Updated: m17n-contrib-urdu-1.1.9-3.fc11.noarch
Apr 06 14:28:15 Updated: m17n-contrib-tamil-1.1.9-3.fc11.noarch
Apr 06 14:28:15 Updated: xorg-x11-drv-evdev-2.2.1-2.fc11.x86_64
Apr 06 14:28:15 Updated: m17n-contrib-assamese-1.1.9-3.fc11.noarch
Apr 06 14:28:16 Updated: gdb-6.8.50.20090302-15.fc11.x86_64
Apr 06 14:28:16 Updated: m17n-contrib-telugu-1.1.9-3.fc11.noarch
Apr 06 14:28:16 Updated: m17n-contrib-kannada-1.1.9-3.fc11.noarch
Apr 06 14:28:17 Updated: 2:qemu-system-x86-0.10-6.fc11.x86_64
Apr 06 14:28:17 Updated: m17n-contrib-punjabi-1.1.9-3.fc11.noarch
Apr 06 14:28:17 Updated: 2:qemu-img-0.10-6.fc11.x86_64
Apr 06 14:28:18 Updated: m17n-contrib-gujarati-1.1.9-3.fc11.noarch
Apr 06 14:28:18 Updated: m17n-contrib-bengali-1.1.9-3.fc11.noarch
Apr 06 14:28:18 Updated: squashfs-tools-4.0-1.x86_64
Apr 06 14:28:18 Updated: xorg-x11-drv-evdev-devel-2.2.1-2.fc11.x86_64
Apr 06 14:31:14 Updated: kernel-firmware-2.6.29.1-52.fc11.noarch
Apr 06 14:31:29 Updated: kernel-doc-2.6.29.1-52.fc11.noarch
Apr 06 14:31:31 Updated: kernel-headers-2.6.29.1-52.fc11.x86_64
Apr 06 14:31:45 Installed: kernel-2.6.29.1-52.fc11.x86_64
Apr 06 14:32:04 Updated: libdrm-2.4.5-4.fc11.x86_64
Apr 06 14:32:04 Updated: libdrm-2.4.5-4.fc11.i586
Apr 06 14:32:05 Updated: libdrm-devel-2.4.5-4.fc11.x86_64
Apr 06 14:32:05 Updated: xorg-x11-drv-ati-6.12.1-5.fc11.x86_64

Since the messages reference drm, maybe libdrm or the kernel broke something?  Also, the messages seem to be related to my wife's use of Firefox on Facebook running the "Hatchlings" application, though that's just a correlation.
Comment 2 Harald Hoyer 2009-04-07 06:05:38 EDT
Does the directory "/dev/.udev/db/" exist?
What is the contents of "/proc/mounts"?
Comment 3 Harald Hoyer 2009-04-07 06:06:36 EDT
can you do:
# touch '/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0'
Comment 4 Mace Moneta 2009-04-07 19:20:41 EDT
OK, I waited for it to start again (my wife using Firefox on a crochet website this time):

Apr  7 19:05:55 shadow udevd-event[27774]: unable to create db file '/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0': No such file or directory

The file exists:

# ls -lZ '/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0'
lrwxrwxrwx. root root system_u:object_r:device_t:s0    /dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.0\x2fdrm\x2fcard0 -> dri/card0 char/226:0

/proc/mounts:

# cat /proc/mounts
rootfs / rootfs rw 0 0
/dev/root / ext3 rw,noatime,relatime,errors=continue,user_xattr,acl,data=ordered 0 0
/dev /dev tmpfs rw,relatime,mode=755 0 0
/proc /proc proc rw,relatime 0 0
/sys /sys sysfs rw,relatime 0 0
none /selinux selinuxfs rw,relatime 0 0
/proc/bus/usb /proc/bus/usb usbfs rw,relatime 0 0
devpts /dev/pts devpts rw,relatime,gid=5,mode=620,ptmxmode=000 0 0
/dev/sda1 /boot ext3 rw,noatime,relatime,errors=continue,user_xattr,acl,data=ordered 0 0
tmpfs /dev/shm tmpfs rw,rootcontext=system_u:object_r:tmpfs_t:s0,relatime 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw,relatime 0 0
gvfs-fuse-daemon /home/bmoneta/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,relatime,user_id=501,group_id=502 0 0
encfs /home/bmoneta/.app-configfiles fuse.encfs rw,nosuid,nodev,relatime,user_id=501,group_id=502,default_permissions 0 0
Comment 5 Mace Moneta 2009-04-07 19:25:30 EDT
I think the symlink is bad.  It's pointing to a non-existent file:

"dri/card0 char/226:0"

But I think it should be pointing to:

/dev/dri/card0
Comment 6 Bug Zapper 2009-06-09 09:22:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Harald Hoyer 2009-06-30 06:27:04 EDT
is this still an issue?
Comment 8 Mace Moneta 2009-06-30 14:07:37 EDT
I haven't seen it in a while.  It appears to have been corrected at some point.