Bug 4952

Summary: gtk-config gives incorrect compiler flags
Product: [Retired] Red Hat Linux Reporter: clemons
Component: gtk+Assignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-07 18:20:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description clemons 1999-09-07 14:36:53 UTC
Try the following:

# /usr/bin/gtk-config --cflags
-I/usr/X11R6/include -I/usr/lib/glib/include

The directory /usr/lib/glib/include does not exist in a
fresh install of Red Hat 6.0.

Comment 1 Elliot Lee 1999-09-07 18:20:59 UTC
Install the glib-devel package. It is listed as a dependency of the
gtk+-devel package. If you override dependencies, you are on your own.