Bug 495993

Summary: System suspends again after waking up
Product: [Fedora] Fedora Reporter: Richard Körber <redhat>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: amcnabb, cweyl, itamar, kernel-maint, p, sassmann, steve
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-07-29 09:09:40 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Richard Körber 2009-04-15 17:27:07 EDT
Description of problem:
I suspend the system to RAM using the Fn+F4 key. When waking the system up, the desktop is shown for a second, but then the system immediately suspends to RAM again. I always have to wake the system up three times until it is finally up again.

When I have suspended to RAM using the Gnome "turn off" dialog, the system wakes up correctly though.

It is a Lenovo ThinkPad R61 with Intel graphics.

Version-Release number of selected component (if applicable):
Fedora 10 x86_64 with all updates applied.
Kernel 2.6.27.21-170.2.56.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Suspend to RAM using Fn+F4.
2. Wake up using the power button.
3. Wake up two more times to finally get the system working again.
  
Actual results:
When waking up, the desktop is shown for a second, and then the system suspends to RAM again.

Expected results:
System just wakes up.

Additional info:
With an earlier ThinkPad R61 model, Intel graphics, F10 x86_64 and all updates applied, the Fn+F4 suspend is working fine. I have no idea why the affected system should behave differently, but it does.

There is no obvious hint in dmesg why the system immediately goes to sleep again.
Comment 1 Andrew McNabb 2009-04-21 17:57:24 EDT
I've had something like this happen with a Samsung NC10 laptop.  I've never had to wake up more than twice total, but it is still very annoying.
Comment 2 Steven Bularca 2009-06-19 02:36:08 EDT
Hi

this problem has persisted on my laptop even with a fresh Fedora 11 install, so I will mark this bug for Fedora version 11.
Comment 3 Chris Weyl 2009-07-02 03:18:19 EDT
I'm seeing much the same happen here, on a Thinkpad T61 / F-11, and am certainly willing to provide any needed information to help resolve this...
Comment 4 Pádraig Brady 2009-07-29 08:41:53 EDT
I think this is a dupe of 475585
Comment 5 Richard Körber 2009-07-29 09:09:40 EDT
Yes, it's a dupe. I am closing this one.

*** This bug has been marked as a duplicate of bug 475585 ***