Bug 496218

Summary: Upgrade of numpy to version 1.3.0-2 breaks games
Product: [Fedora] Fedora Reporter: Jared Smith <jsmith.fedora>
Component: numpyAssignee: Jon Ciesla <limburgher>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: jarod, jspaleta, limburgher, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-17 10:36:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jared Smith 2009-04-17 07:44:27 EDT
Description of problem:

My son loves to play the "slingshot" game on my rawhide box.  Yesterday, as part of my daily rawhide update, the numpy package got updated.  Now slingshot doesn't work.

Version-Release number of selected component (if applicable):

[root@localhost ~]# rpm -q python python-devel slingshot numpy
python-2.6-7.fc11.i586
python-devel-2.6-7.fc11.i586
slingshot-0.8.1p-3.fc11.noarch
numpy-1.3.0-2.fc11.i586


How reproducible:

All the time

Steps to Reproduce:
1. Update a box to the latest from rawhide
2. Install slingshot
3. Try to run the game
  
Actual results:

[jsmith@localhost ~]$ slingshot 
Traceback (most recent call last):
  File "slingshot.py", line 31, in <module>
    import pygame
  File "/usr/lib/python2.6/site-packages/pygame/__init__.py", line 188, in <module>
    try: import pygame.sndarray
  File "/usr/lib/python2.6/site-packages/pygame/sndarray.py", line 73, in <module>
    import pygame._numpysndarray as numpysnd
  File "/usr/lib/python2.6/site-packages/pygame/_numpysndarray.py", line 38, in <module>
    import numpy
  File "/usr/lib/python2.6/site-packages/numpy/__init__.py", line 130, in <module>
    import add_newdocs
  File "/usr/lib/python2.6/site-packages/numpy/add_newdocs.py", line 9, in <module>
    from lib import add_newdoc
  File "/usr/lib/python2.6/site-packages/numpy/lib/__init__.py", line 13, in <module>
    from polynomial import *
  File "/usr/lib/python2.6/site-packages/numpy/lib/polynomial.py", line 11, in <module>
    import numpy.core.numeric as NX
AttributeError: 'module' object has no attribute 'core'


Expected results:

The game should run.

Additional info:

numpy-1.3.0-1.fc11.i586 was the previous package I had installed, and it worked fine.
Comment 1 Jon Ciesla 2009-04-17 08:28:42 EDT
I also maintain slingshot :)  Slingshot requires pygame which requires numpy.

The update to numpy was to split off the f2py portion into a subpackage.  Checks were done on all of numpy's dependencies, and I didn't think pygame needed f2py.  I need to determine whether slingshot or pygame was broken by this.  Here's what I'd like you to do:

1. yum install solarwolf, and see if it works.  It also uses pygame.
2. yum install numpy-f2py, and re-test slingshot and solarwolf.
3. Post the results here.

Thanks!
Comment 2 Jared Smith 2009-04-17 09:01:13 EDT
Thanks for your help.

Solarwolf had the exact same problem as slingshot.

Once I installed numpy-f2py, both games worked fine.  Sounds like we have some missing dependencies.  

Solarwolf also printed the following warning to the console, but it didn't seem to have any effect on the game.

[jsmith@localhost /]$ solarwolf
/usr/lib/python2.6/site-packages/pygame/sysfont.py:139: DeprecationWarning: os.popen3 is deprecated.  Use the subprocess module.
  flin, flout, flerr = os.popen3('fc-list : file family style')
Exception TypeError: TypeError("'NoneType' object is not callable",) in <bound method Popen.__del__ of <subprocess.Popen object at 0x872c10c>> ignored
Comment 3 Jon Ciesla 2009-04-17 09:10:30 EDT
Awesome. I'll modify pygame to require numpy-f2py.  Thanks for your help!
Comment 4 Jon Ciesla 2009-04-17 09:43:57 EDT
Built in rawhide and F-11, Freeze Exception ticket:

https://fedorahosted.org/rel-eng/ticket/1508
Comment 5 Jon Ciesla 2009-04-17 10:36:37 EDT
Tagged for F-11.