Bug 497319

Summary: Pulseaudio suddenly stopped working: snd_pcm_avail_update() returned a value that is exceptionally large
Product: [Fedora] Fedora Reporter: Stefan Jensen <sjensen>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 10CC: lkundrak, lpoetter, wtogami, yaneti
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-23 12:04:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
similar log none

Description Stefan Jensen 2009-04-23 07:48:30 EDT
Description of problem:

Pulseaudio suddenly stopped working and can't auto start anymore. Manual start fails also.

Version-Release number of selected component (if applicable):

$ rpm -qa| grep pulseaudio
pulseaudio-core-libs-0.9.14-1.fc10.x86_64
pulseaudio-libs-0.9.14-1.fc10.x86_64
pulseaudio-utils-0.9.14-1.fc10.x86_64
pulseaudio-module-x11-0.9.14-1.fc10.x86_64
pulseaudio-module-zeroconf-0.9.14-1.fc10.x86_64
pulseaudio-module-jack-0.9.14-1.fc10.x86_64
xine-lib-pulseaudio-1.1.16.3-2.fc10.x86_64
pulseaudio-libs-devel-0.9.14-1.fc10.x86_64
alsa-plugins-pulseaudio-1.0.18-2.fc10.x86_64
pulseaudio-libs-zeroconf-0.9.14-1.fc10.x86_64
pulseaudio-module-gconf-0.9.14-1.fc10.x86_64
pulseaudio-module-bluetooth-0.9.14-1.fc10.x86_64
pulseaudio-libs-glib2-0.9.14-1.fc10.x86_64
pulseaudio-module-lirc-0.9.14-1.fc10.x86_64
pulseaudio-esound-compat-0.9.14-1.fc10.x86_64
pulseaudio-0.9.14-1.fc10.x86_64

How reproducible:

Always

Steps to Reproduce:

1. try start ./pulseaudio
  
Actual results:

No playback of audio. Starting pulseaudio failed with:

I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
W: pid.c: Stale PID file, overwriting.
W: alsa-util.c: Device hw:2 doesn't support 44100 Hz, changed to 48000 Hz.
W: alsa-util.c: Cannot find fallback mixer control "Mic".
W: alsa-util.c: Device hw:0 doesn't support 44100 Hz, changed to 16000 Hz.
W: alsa-util.c: Device hw:0 doesn't support 2 channels, changed to 1.
W: module-alsa-source.c: Your kernel driver is broken: it reports a volume range from 5,00 dB to 5,00 dB which makes no sense.
E: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 18446744073709486080 bytes (384307167860 ms) Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers.
N: module-alsa-source.c: Increasing wakeup watermark to 36,75 ms
Soft CPU time limit exhausted, terminating.
Hard CPU time limit exhausted, terminating forcibly.
Abgebrochen

Expected results:

pulseausio start up correctly and can play audio.

Additional info:

$ lsmod | grep snd
snd_hda_codec_analog    76160  1 
snd_hda_intel          28792  1 
snd_hda_codec          63424  2 snd_hda_codec_analog,snd_hda_intel
snd_usb_audio          93712  0 
snd_seq_dummy           3108  0 
snd_seq_oss            31424  0 
snd_seq_midi_event      6656  1 snd_seq_oss
snd_seq                54032  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            43344  0 
snd_mixer_oss          15216  1 snd_pcm_oss
snd_pcm                78184  5 saa7134_alsa,snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_pcm_oss
snd_usb_lib            16688  1 snd_usb_audio
snd_rawmidi            22608  1 snd_usb_lib
snd_timer              22160  2 snd_seq,snd_pcm
snd_seq_device          7060  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd_hwdep               8296  2 snd_hda_codec,snd_usb_audio
snd_page_alloc          8976  2 snd_hda_intel,snd_pcm
snd                    63448  18 saa7134_alsa,snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_seq_dummy,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_usb_lib,snd_rawmidi,snd_timer,snd_seq_device,snd_hwdep

$ lspci| grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

best regards
Comment 1 Yanko Kaneti 2009-04-23 08:07:21 EDT
Created attachment 340929 [details]
similar log

Here is a similar log, which is always reproducible when starting gnome-volume-control. I've tried both kernel-2.6.29.1-106.fc11.x86_64 and kernel-2.6.30-0.66.rc3.fc12.x86_64 with similar results.

some kernel spew wrt this hardware..
HDA Intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16
hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3795: autoconfig: line_outs=4 (0x14/0x15/0x16/0x17/0x0)
ALSA sound/pci/hda/hda_codec.c:3799:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3803:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3804:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3807:    dig-out=0x1e/0x0
ALSA sound/pci/hda/hda_codec.c:3815:    inputs: mic=0x18, fmic=0x19, line=0x1a, fline=0x0, cd=0x0, aux=0x0
ALSA sound/pci/hda/hda_codec.c:3817:    dig-in=0x1f
input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:14.2/input/input6
HDA Intel 0000:01:05.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
HDA Intel 0000:01:05.1: setting latency timer to 64
......
ALSA sound/pci/hda/hda_intel.c:1102: Too big adjustment 32
......many time this....
Comment 3 Lennart Poettering 2009-04-23 12:04:22 EDT

*** This bug has been marked as a duplicate of bug 485734 ***