This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 499060

Summary: vgabios regression - 1440x900 resolution no longer available
Product: [Fedora] Fedora Reporter: Howard Ning <mrlhwliberty>
Component: vgabiosAssignee: Glauber Costa <gcosta>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 11CC: berrange, clalance, dwmw2, ehabkost, gcosta, markmc, quintela, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.6b-2.fc11 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-07-11 13:00:51 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 480594    
Attachments:
Description Flags
Xorg.0.log none

Description Howard Ning 2009-05-04 22:35:52 EDT
Created attachment 342404 [details]
Xorg.0.log

Description of problem:
qemu-kvm with -vga std does not provide widescreen resolution in win xp guest.
In fedora 10 with qemu-kvm 0.91, it provide 1440x900 resolution. but it does not provide in newer 0.10.1

Version-Release number of selected component (if applicable):
0.10.1

How reproducible:
run
$qemu-kvm -m 1024 -soundhw es1370 -cdrom ~/Public/winxpsp2.iso -usb -localtime -usbdevice tablet -vga std -hda /home/Liberty/xp.img
to start the windows xp guest, go to resolution selector in the guest. it does not provide widescreen resolution like in fedora 10.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mark McLoughlin 2009-05-05 05:43:07 EDT
Glauber: any ideas why this would have worked in 0.9.1 but not 0.10? vgabios differences perhaps?
Comment 2 Mark McLoughlin 2009-05-05 05:44:53 EDT
liberty: could you try using the vga /usr/share/qemu/vgabios.bin file from 0.9.1 with 0.10 and see if that makes it work?
Comment 3 Howard Ning 2009-05-05 09:55:40 EDT
I have tried replaced the vgabios with the 0.9.1 one. 
It provides me all the widescreen resolution and fixed this problem.
Comment 4 Mark McLoughlin 2009-05-05 12:42:36 EDT
Thanks much. Moving to vgabios
Comment 5 Glauber Costa 2009-05-05 17:50:28 EDT
I don't really know. QEMU does not add any patches to vgabios, so it is probably a vgabios regression itself.

Will take a look
Comment 6 Fedora Update System 2009-05-18 21:25:00 EDT
vgabios-0.6-0.6.c.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/vgabios-0.6-0.6.c.fc11
Comment 7 Fedora Update System 2009-05-19 20:48:59 EDT
vgabios-0.6-0.6.c.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vgabios'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5180
Comment 8 Howard Ning 2009-05-20 19:55:39 EDT
I have tried but the result is even worse.
I upgraded to the vgabios-0.6-0.5.b.fc11_0.6-0.6.c.fc11.noarch.drpm, and then start a windows xp vm using 
env QEMU_AUDIO_DRV=pa qemu-kvm -m 1024 -soundhw es1370 -localtime -usbdevice tablet -vga std -hda xp.img
The screen resolution fall back to 640x480 and the color depth is 4bit now.

Using cirrcus is OK. But it still does not provide 1440x900 resolution.
Comment 9 Howard Ning 2009-05-20 19:59:19 EDT
Windows 7 RC VM get the same result, 640x480x4bit, cannot change resolution.
Comment 10 Mark McLoughlin 2009-05-21 10:02:11 EDT
(In reply to comment #8)
> I have tried but the result is even worse.

Thanks for trying and commenting here; it's also helpful if you add a comment using the link above to change the "karma" for the update
Comment 11 Mark McLoughlin 2009-05-21 14:25:54 EDT
Note, the added problems with 0.6c is confirmed by bug #501545, we've unpushed the update from F-11 now
Comment 12 Bug Zapper 2009-06-09 11:08:54 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Mark McLoughlin 2009-06-19 11:23:02 EDT
Just posted the following to bug #501545:

  1) upstream qemu-kvm vgabios added support for higher resolutions back
     in kvm-62:

  http://git.kernel.org/?p=virt/kvm/qemu-kvm.git;a=commitdiff;h=ebfac597cf

  2) in F-11 we started using upstream vgabios-0.6b, which didn't have this
     patch - hence bug #499060

  3) 0.6c *does* have this patch, but it also has other changes which are
     incompatible with current qemu - it requires both 
     VBE_DISPI_INDEX_VIDEO_MEMORY_64K and VBE_DISPI_ID5 to be present

  4) F-11 bochs has this support, but qemu has its own version of the code
     which needs to be updated

Nickel summary - we'll have 0.6c for F-12, but we need qemu updated to support it; we'll patch 0.6b with the patch linked to above for F-11 and that will fix bug #499060
Comment 14 Fedora Update System 2009-06-19 11:57:28 EDT
vgabios-0.6b-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/vgabios-0.6b-2.fc11
Comment 15 Glauber Costa 2009-06-20 09:17:54 EDT
Guys, please test and karma it.
Comment 16 Fedora Update System 2009-06-24 15:28:54 EDT
vgabios-0.6b-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vgabios'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6920
Comment 17 Howard Ning 2009-06-25 08:35:54 EDT
I have tested it. It seems to be fixed in this version. I can use 1440x900 resolution
Comment 18 Mark McLoughlin 2009-07-03 03:25:17 EDT
Thanks for testing Liberty - in future, please follow the link posted by "Fedora Update System" and add your testing results there too; if enough people do that, the update gets pushed to stable automatically
Comment 19 Howard Ning 2009-07-03 06:35:09 EDT
(In reply to comment #18)
> Thanks for testing Liberty - in future, please follow the link posted by
> "Fedora Update System" and add your testing results there too; if enough people
> do that, the update gets pushed to stable automatically  

I have posted my possitive comments to the update system before posting here. Thanks for your reminding.
Comment 20 Fedora Update System 2009-07-11 13:00:45 EDT
vgabios-0.6b-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.