Bug 499596

Summary: 32 bit KVM guest hangs enabling NX protection; booting with -cpu qemu32 works
Product: [Fedora] Fedora Reporter: Jan ONDREJ <ondrejj>
Component: qemuAssignee: Glauber Costa <gcosta>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 11CC: dwmw2, gcosta, knoel, markmc, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.10.5-2.fc11 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-15 22:28:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 480594    
Attachments:
Description Flags
/proc/cpuinfo none

Description Jan ONDREJ 2009-05-07 07:29:57 EDT
Description of problem:
When trying to install F11-Preview under KVM, it freezes. At time of hard disk detection. I can install my guest in text mode. May be something is wrong after graphics initialization, but I am not sure.

My HW (notebook) is 32bit only with VT support.

Version-Release number of selected component (if applicable):
guest:
kernel-PAE-2.6.29.1-102.fc11.i686 - no messages
kernel-PAE-2.6.29.2-126.fc11.i686 - see serial 0 output below

host:
qemu-0.10-16.fc11.i586
kernel-2.6.29.2-126.fc11.i586

How reproducible:
always for my HW


Steps to Reproduce:
I think it's not easy to reproduce this on different machine, but there are steps, what have been done.
1. install F11-Preview using qemu
2. boot, run "yum update -y"
3. reboot, switch to use KVM
4. when booting, hold shift to stop in GRUB
5. remove "rhgb quiet"
6. add "earlyprintk=serial,ttyS0 console=ttyS0 debug"
7. boot (type b after enter)
  
Actual results:
This was on Serial 0:

Initializing cgroup subsys cpuset
Initializing cgroup subsys cpu
Linux version 2.6.29.2-126.fc11.i686.PAE (mockbuild@xenbuilder2.fedora.redhat.com) (gcc version 4.4.0 20090427 (Red Hat 4.4.0-3) (GCC) ) #1 SMP Mon May 4 04:48:39 EDT 2009
KERNEL supported cpus:
  Intel GenuineIntel
  AMD AuthenticAMD
  NSC Geode by NSC
  Cyrix CyrixInstead
  Centaur CentaurHauls
  Transmeta GenuineTMx86
  Transmeta TransmetaCPU
  UMC UMC UMC UMC
PAT WC disabled due to known CPU erratum.
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
 BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000e8000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000000fff0000 (usable)
 BIOS-e820: 000000000fff0000 - 0000000010000000 (ACPI data)
 BIOS-e820: 00000000fffbc000 - 0000000100000000 (reserved)
console [earlyser0] enabled
DMI 2.4 present.
last_pfn = 0xfff0 max_arch_pfn = 0x1000000
kernel direct mapping tables up to fff0000 @ 7000-e000
NX (Execute Disable) protection: active

After this line nothing more.
And this on Console:
Probing EDD (dcc=off to disable)... ok

Expected results:
Working system.

Additional info:
With command:
  qemu-kvm -cpu qemu32 /var/lib/libvirt/images/${guest}.img" -serial stdio
system boots well.
Comment 1 Mark McLoughlin 2009-05-07 07:35:11 EDT
Can you attach your /proc/cpuinfo ?
Comment 2 Mark McLoughlin 2009-05-07 07:37:32 EDT
Comments from avi:

<markmc>        avi, 32-on-32 bit kvm guest freezes here http://pastebin.com/m2355b339
<markmc>        avi, boots fine under tcg
<markmc>        avi, ideas for debugging it ?
<avi>   I know what it is
<avi>   try -cpu qemu32 or -cpu qemu64,-nx
<avi>   it's a mess of bugs
<avi>   see my cpuid patches submitted to qemu upstream making use of GET_SUPPORTED_CPUID
<avi>   still trying to think of a proper fix
<avi>   wrt kernel f84c427c8afbe84
<markmc>        avi, just to be clear - f84c427c8afbe84 should fix the hang ?
<avi>   no, f8 fixes cpuid reporting
<avi>   together with the patchset that uses reporting, it should fix the hang
Comment 3 Jan ONDREJ 2009-05-07 08:01:51 EDT
Created attachment 342827 [details]
/proc/cpuinfo

/proc/cpuinfo on host
Comment 4 Fedora Admin XMLRPC Client 2009-05-07 08:12:39 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2009-05-07 08:13:41 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2009-05-07 08:14:08 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2009-05-07 13:58:29 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Update System 2009-05-18 23:36:50 EDT
qemu-0.10.4-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.4-5.fc11
Comment 9 Jan ONDREJ 2009-05-19 06:14:12 EDT
qemu-0.10.4-5.fc11.i586

still same problem.
Comment 10 Fedora Update System 2009-05-19 20:48:14 EDT
qemu-0.10.4-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5174
Comment 11 Mark McLoughlin 2009-05-21 15:09:59 EDT
(In reply to comment #9)
> qemu-0.10.4-5.fc11.i586
> 
> still same problem.  

Thanks for trying Jan. Glauber back-ported the cpuid trimming patches to the stable branch and they were included in the qemu-0.10.5 release. We'll get a proper update with it soon.

Note: this may not fix your problem, since your host does have NX support, but it's worth a try
Comment 12 Fedora Update System 2009-05-31 11:34:49 EDT
qemu-0.10.5-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.5-1.fc11
Comment 13 Jan ONDREJ 2009-06-02 09:38:55 EDT
(In reply to comment #12)
> qemu-0.10.5-1.fc11 has been submitted as an update for Fedora 11.
> http://admin.fedoraproject.org/updates/qemu-0.10.5-1.fc11  

Where is this update? It's still not in fedora-11-updates-testing repository on master mirror. Something is wrong?

http://download1.fedora.redhat.com/pub/fedora/linux/updates/testing/11/SRPMS/

This is now aprox. 2 days after message from bodhi.
Comment 14 Fedora Update System 2009-06-02 10:29:53 EDT
qemu-0.10.5-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5776
Comment 15 Fedora Update System 2009-06-03 12:21:15 EDT
qemu-0.10.5-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.5-2.fc11
Comment 16 Jan ONDREJ 2009-06-04 03:43:19 EDT
(In reply to comment #15)
> qemu-0.10.5-2.fc11 has been submitted as an update for Fedora 11.
> http://admin.fedoraproject.org/updates/qemu-0.10.5-2.fc11  

Still no success on my machines. I have 2 machines:
  1. notebook F11 (this is machine, for which this bug has been reported)
  2. workstation with F10 + some updates (qemu, virt-manager, ...) with nx support

Same problem on both of them, unable to boot rawhide (F11) with all updates.

Even if this does not boot for me, it looks NX problem is fixed and F11 does not boot with virtio driver, as described in bug 499601.
Comment 17 Mark McLoughlin 2009-06-04 07:22:21 EDT
(In reply to comment #16)
> (In reply to comment #15)
> > qemu-0.10.5-2.fc11 has been submitted as an update for Fedora 11.
> > http://admin.fedoraproject.org/updates/qemu-0.10.5-2.fc11  
> 
> Still no success on my machines. I have 2 machines:
>   1. notebook F11 (this is machine, for which this bug has been reported)

Let's concentrate on this one, for now.

Does the guest still hang at this point:

  NX (Execute Disable) protection: active

as you described in comment #0 ?
Comment 18 Jan ONDREJ 2009-06-04 07:33:35 EDT
> Does the guest still hang at this point:
> 
>   NX (Execute Disable) protection: active
> 
> as you described in comment #0 ?  

Does not hang, works well after this line.
I think this bug should be closed as fixed.
Comment 19 Mark McLoughlin 2009-06-04 09:21:21 EDT
(In reply to comment #18)
> > Does the guest still hang at this point:
> > 
> >   NX (Execute Disable) protection: active
> > 
> > as you described in comment #0 ?  
> 
> Does not hang, works well after this line.
> I think this bug should be closed as fixed.  

Thanks, it'll be closed automatically when the update goes to stable
Comment 20 Bug Zapper 2009-06-09 11:18:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Fedora Update System 2009-06-15 22:28:11 EDT
qemu-0.10.5-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.