This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 499601

Summary: KVM guest fails to boot with if=virtio; works with if=ide
Product: [Fedora] Fedora Reporter: Jan ONDREJ <ondrejj>
Component: qemuAssignee: Glauber Costa <gcosta>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: dwmw2, gcosta, markmc, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-04 09:22:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 480594    

Description Jan ONDREJ 2009-05-07 07:58:07 EDT
Description of problem:
After I was able to boot my guest as described in bz#499596, my guest fails again at startup. Changing drive interface from virtio to ide helps to boot.

Version-Release number of selected component (if applicable):
qemu-0.10-16.fc11.i586
kernel-2.6.29.2-126.fc11.i586

How reproducible:
always for me

Steps to Reproduce:
1. follow steps in https://bugzilla.redhat.com/show_bug.cgi?id=499596
2. run /usr/bin/qemu-kvm -cpu qemu32 -boot c -drive file=rawhide.img,if=virtio,index=0,boot=on -serial stdio

Actual results:
Initalizing network drop monitor service
Freeing unused kernel memory: 436k freed
Write protecting the kernel read-only data: 1460k
Mounting proc filesystem
Mounting sysfs filesystem
Creating /dev
Creating initial device nodes
input: ImExPS/2 Generic Explorer Mouse as /devices/platform/i8042/serio1/input/input3

Nothing else on serial console.

Expected results:
booted system

Additional info:
Comment 1 Mark McLoughlin 2009-05-07 08:06:08 EDT
As glommer points out, this could be an extboot issue - with IDE, if extboot fails then boot can still succeed, but this is not true for virtio

Also, note that this is a 32 bit host
Comment 2 Glauber Costa 2009-05-07 08:09:18 EDT
After looking at the bug report in details, it is probably _not_ an extboot
related issue. extboot only serves the purpose of booting the system. It seems this step is passed for this guy.
Comment 3 Fedora Admin XMLRPC Client 2009-05-07 08:11:58 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2009-05-07 08:13:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2009-05-07 08:13:33 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2009-05-07 13:57:57 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Glauber Costa 2009-05-18 21:29:52 EDT
Does this still happen ?
Comment 8 Jan ONDREJ 2009-05-19 06:08:52 EDT
Yes, still problem with qemu-0.10.4-5.fc11.i586.
Comment 9 Mark McLoughlin 2009-06-04 07:26:57 EDT
Could you boot the guest in qemu and confirm that the initrd.img in /boot has the virtio drivers included?

  $> gzip -cd < /boot/initrd...img | cpio -ivt --quiet | grep virtio

I think you installed without virtio originally, which would explain it.

To fix that, you just need to run e.g.

  $> mkinitrd --with virtio_pci --with virtio_blk -f \
              /boot/initrd-$(uname -r).img $(uname -r)
Comment 10 Jan ONDREJ 2009-06-04 07:41:40 EDT
(In reply to comment #9)
> Could you boot the guest in qemu and confirm that the initrd.img in /boot has
> the virtio drivers included?
> 
>   $> gzip -cd < /boot/initrd...img | cpio -ivt --quiet | grep virtio

Resulted with no output.

> I think you installed without virtio originally, which would explain it.

I think this was broken when I updated my kernel without virtio driver, because virtio was not functional for me in previous releases.

Todays installation of Leonidas worked well.

> To fix that, you just need to run e.g.
> 
>   $> mkinitrd --with virtio_pci --with virtio_blk -f \
>               /boot/initrd-$(uname -r).img $(uname -r)  

This also fixed my problem.

You can close this bug too.
Comment 11 Mark McLoughlin 2009-06-04 09:22:26 EDT
Excellent, thanks