This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 501550

Summary: virtio console device has lame PCI class info
Product: [Fedora] Fedora Reporter: Adam Jackson <ajax>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: dwmw2, gcosta, itamar, markmc, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-11 14:23:29 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
qemu-0.10.4-virtio-console-pci-class.patch none

Description Adam Jackson 2009-05-19 13:38:50 EDT
Description of problem:

00:05.0 Unclassified device [00ff]: Qumranet, Inc. Virtio console
        Subsystem: Qumranet, Inc. Device 0003
        Physical Slot: 5
        Flags: fast devsel, IRQ 10
        I/O ports at c220 [size=32]
        Kernel driver in use: virtio-pci
        Kernel modules: virtio_pci

While this is valid, many versions of X will get confused by it.  Class major number of 0 gets treated as a possibly prehistoric VGA device, and then the autoconfig logic gets confused trying to figure out whether the virtio console or the pv vga device are the real VGA.

Worked around in the X server in F11, but we should really set a proper class ID.  0x0780 (serial / other) seems most appropriate.  Attached patch does this.  Shouldn't require any kernel changes, the modalias for virtio looks like:

alias:          pci:v00001AF4d*sv*sd*bc*sc*i*

so won't care what the base class or subclass are.

Version-Release number of selected component (if applicable):

qemu-system-x86-0.10-16.fc11.i586
Comment 1 Adam Jackson 2009-05-19 13:39:31 EDT
Created attachment 344655 [details]
qemu-0.10.4-virtio-console-pci-class.patch
Comment 2 Mark McLoughlin 2009-05-22 13:16:16 EDT
Interesting that qemu-kvm actually changed from qemu's PCI_CLASS_DISPLAY_OTHER:

  http://git.kernel.org/?p=virt/kvm/qemu-kvm.git;a=commitdiff;h=4667e6ec0d

I've posted a re-based version of your patch to qemu-devel:

  Subject: [PATCH] Change virtio-console to PCI_CLASS_SERIAL_OTHER
Comment 3 Bug Zapper 2009-06-09 12:07:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Admin XMLRPC Client 2010-03-09 11:54:04 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2010-03-09 12:17:36 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Justin M. Forbes 2010-03-11 14:23:29 EST
This should be fixed in qemu 0.12.x