This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 502270

Summary: NetworkManager fails to connect to wireless WPA network (timing problem?)
Product: [Fedora] Fedora Reporter: Matthias Runge <mrunge>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: danw, dcbw, josep.puigdemont
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-11 12:33:01 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
/var/log/messages none

Description Matthias Runge 2009-05-22 17:30:17 EDT
Created attachment 345165 [details]
/var/log/messages

Description of problem:
After boot, NetworkManager tries automatically to connect to a visible wpa secured network. This takes too long and NM asks for the key. At second time, association succeeds.


Version-Release number of selected component (if applicable):
NetworkManager-0.7.1-4.git20090414.fc11.i586
wpa_supplicant-0.6.8-2.fc11.i586
kernel-PAE-2.6.29.3-155.fc11.i686

How reproducible:
90%

Steps to Reproduce:
1. Boot, log in
2. NM tries to connect
3.
  
Actual results:
No connection is made, NM asks for key


Expected results:
Connection succeeds, no further assistance necessary


Additional info:
0b:02.0 Ethernet controller: Atheros Communications Inc. AR5212 802.11abg NIC (rev 01)
(i.e. ath5k driver)
Comment 1 Matthias Runge 2009-06-02 05:40:51 EDT
maybe a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=463110
Comment 2 Bug Zapper 2009-06-09 12:24:07 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matthias Runge 2009-06-11 09:00:20 EDT
Seems to be no problem, if using kernel 2.6.30.....
Comment 4 Josep 2009-07-26 12:08:19 EDT
Same problem. I have not yet been able to establish a connection to a WPA router. The logs look the same as shown in the attached file.

I have no trouble with a WPA2 router, though. It worked flawlessly on Fedora 10.

Additional info:
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
Comment 5 Matthias Runge 2009-08-17 03:29:01 EDT
Seems to be fixed with the 2.6.30 (testing) kernel from koji.
Comment 6 Dan Williams 2009-11-11 12:33:01 EST
Yeah, 2.6.30 (F11) kernels work pretty well with a dual-band ath5k for me with WPA-PSK as well.  Closing...  Final diagnosis is a kernel driver bug.