Bug 503270

Summary: F10 is wrongly marked as not OK for preupgrade
Product: [Fedora] Fedora Reporter: Michal Schmidt <mschmidt>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 10CC: wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-01 11:50:59 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Michal Schmidt 2009-05-30 09:26:29 EDT
Attempting to upgrade an F9 installation I was surprised that F10 was not offered as an option in preupgrade. After adding a few debug prints I discovered that preupgrade uses http://mirrors.fedoraproject.org/releases.txt where F10 is intentionally blocked for preupgrade:

...
# https://bugzilla.redhat.com/show_bug.cgi?id=499321
# prevents this from ever succeeding on F10.
[Fedora 10 (Cambridge)]
stable=True
preupgrade-ok=False
...


This is surprising because BZ499321 does not seem to be about F10 at all.
The comment is also provably false: I downloaded the releases.txt file, edited it to say 'preupgrade-ok=True' and made preupgrade use my modified file and then preupgrade worked perfectly without any problem. It resulted in a working F10 system.

Please allow F9->F10 using preupgrade in releases.txt.
Comment 1 Will Woods 2009-06-01 11:50:59 EDT
You (and the author of that comment) are a bit confused.

F10 is marked 'preupgrade-ok=False' because F10 anaconda does not support some of the kickstart commands needed by preupgrade to ensure a successful upgrade. Therefore F10 is not suitable for preupgrade.

It *may* work for *you*, but there are some known problems so it's not guaranteed to work properly for other people. It's safer to just upgrade straight to F11.

Bug 499321 is not relevant here.
Comment 2 Will Woods 2009-06-02 14:56:14 EDT
Did a quick code review and realized that preupgrade is smart enough to skip the kickstart commands that F10 doesn't understand.

We'll be marking F10 as preupgrade-ok shortly, but bear in mind that preupgrading to will misbehave if you have multiple Fedora installations due to the lack of the '--root-device=XXX' option. See this bug for details:

https://bugzilla.redhat.com/show_bug.cgi?id=473271#c9