This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 505717

Summary: How to autostart gnote without gnome-panel?
Product: [Fedora] Fedora Reporter: Rajeesh <rajeeshknambiar>
Component: gnoteAssignee: Rahul Sundaram <sundaram>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: bmillett, dodji, hfiguiere, jspaleta, metherid, smohan, sundaram, timur.kristof
Target Milestone: ---Keywords: MoveUpstream, Reopened, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-09 03:34:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Rajeesh 2009-06-13 00:22:17 EDT
Description of problem:
Gnote doesn't "autostart" - when user login, the tray icon doesn't appear in the panel by default. So added Gnote in the "Startup Applications". On the next login, Gnote brings up "Search All Notes" window instead of just staying at the tray. Closing the "Search All Notes" window causes Gnote to exit - the tray icon also disappears.


Version-Release number of selected component (if applicable):
0.4.0 - fc11
This behaviour is present in version 0.3 also

How reproducible:
Always

Steps to Reproduce:
1. Add Gnote to "Startup Applications"
2. Reboot
3. Login
  
Actual results:
Instead of staying at tray, "Search All Notes" window appears. Closing the window makes Gnote quit

Expected results:
The "Search All Notes" window should not come.
Closing the "Search All Notes" window shouldn't cause Gnote exit.


Additional info:
Comment 1 Rahul Sundaram 2009-06-13 00:27:13 EDT
How about just using the panel applet instead of the application?
Comment 2 Rajeesh 2009-06-13 06:32:48 EDT
Using "/usr/libexec/gnote-applet", or "gnote --panel-applet" doesn't display and tray icon. But gnote is running.
Comment 3 Rahul Sundaram 2009-06-13 07:59:42 EDT
Right click on the panel and click Add to Panel => Gnote
Comment 4 Rajeesh 2009-06-13 09:21:55 EDT
It works. Thanks, Rahul.

But isn't this a workaround, rather than solution?
Comment 5 Rahul Sundaram 2009-06-13 10:24:16 EDT
Moved this bug upstream
Comment 6 Hubert Figuiere 2009-06-13 14:52:14 EDT
This is not a bug.

If you have a GNOME panel, add Gnote to the panel like any other applet.

If you don't have a GNOME panel, make sure the "notification area" is up first.

Using "/usr/libexec/gnote-applet", or "gnote --panel-applet" is NOT supported. It is just a mechanism for the panel to work (because Gnote can be used without panel).

And yes, Tomboy work the exact same way.
Comment 7 Rajeesh 2009-06-13 23:21:56 EDT
Thanks for the update on "gnote --panel-applet".

I've both GNOME panel, and notification area. If I start GNote manually, it goes and stays at the system tray. So I was wondering, what's wrong when starting from GNOME session.

Tomboy always auto-started, and it always stayed in the system tray. As I'm not using Tomboy any more, I can live with adding GNote to the panel.

Thanks!
Comment 8 Hubert Figuiere 2009-06-15 12:18:47 EDT
the problem is that when starting for the session you must ensure the notification area IS running before starting gnote. Maybe the timeout could be increased for Gnote. That's a possible, but afaik it wait already a bit before declaring himself "not in the status icon".

Now since you run a GNOME-panel, you shouldn't be fiddling with the "auto start" and just use the applet. The use of notification area for that is IMHO broken by design.
Comment 9 Rahul Sundaram 2009-06-19 08:13:22 EDT
Rajeesh,

Does the explanation from Hubert Figuiere make sense to you? Can I close this bug report?
Comment 10 Rajeesh 2009-06-19 08:32:04 EDT
Rahul,
Please feel free to do so.

Again, thanks to both of you.
Comment 11 Brian Millett 2009-11-23 16:11:22 EST
Ok, but if you are running gnome-shell there is no gnome-panel.
If it quacks like a duck, then...

I'd say it is still a bug.
Comment 12 Matěj Cepl 2010-12-13 06:21:29 EST
I believe that this IS a duck ... we don't seem to have any good way how to start gnote in gnome-shell. Or do we have?
Comment 13 Hubert Figuiere 2010-12-14 03:34:07 EST
Does the gnome-shell has a notification area? Because if it does not, then you are gonna have to be creative. Otherwise does Tomboy work? If yes then you might be able to save yourself the trouble.

These are all wild guesses as I don't have gnome-shell here.
Comment 14 Rahul Sundaram 2011-01-17 16:28:30 EST
I don't use GNOME Shell yet and I have no idea what GNOME Shell developers recommend in this situation.  If someone is poking them, let me know their feedback on this.
Comment 15 Timur Kristóf 2011-05-08 17:34:07 EDT
It seems to me that gnote version 0.7.4-1 fixes this problem under Gnome Shell.