This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 505905

Summary: Segfault Xvnc
Product: [Fedora] Fedora Reporter: Gaetan Cambier <gaetan>
Component: tigervncAssignee: Adam Tkac <atkac>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: atkac, ovasik, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-21 17:27:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
My vncts file none

Description Gaetan Cambier 2009-06-14 12:13:55 EDT
Description of problem:
When connect on vncserver, it's crash

Version-Release number of selected component (if applicable):
 - vnc-ltsp-config-4.0-6.fc11.noarch
 - xinetd-2.3.14-22.fc11.i586

How reproducible:

Steps to Reproduce:
1. install and configure vnc-ltsp-config-4.0-6.fc11 
2. connect with tigervnc on 127.0.0.1:5900

  
Actual results:
  Message Log :
    xinetd[22841]: START: vnc-1024x768x16 pid=27480 from=::ffff:127.0.0.1
    kernel: Xvnc[27480]: segfault at 0 ip 0820008b sp bf8e3b00 error 4 in Xvnc[8044000+23f000]
Comment 1 Rex Dieter 2009-06-14 14:28:56 EDT
rpm -q -f /usr/bin/Xvnc
tigervnc-server-0.0.90-0.10.fc11.x86_64

re-assigning.
Comment 2 Gaetan Cambier 2009-06-14 14:45:11 EDT
rpm -q -f /usr/bin/Xvnc
tigervnc-server-0.0.90-0.10.fc11.i586
Comment 3 Adam Tkac 2009-06-22 05:24:36 EDT
Could you attach your /etc/xinetd.d/vncts configuration file, please?
Comment 4 Gaetan Cambier 2009-06-22 15:06:26 EDT
Created attachment 348971 [details]
My vncts file
Comment 5 Gaetan Cambier 2009-06-22 16:22:38 EDT
after some test, i realise that only with the arguments "-depth 16" cause a segfault

when i use the argument "-depth 8", the server runing normally.
Comment 6 Adam Tkac 2009-09-04 05:31:09 EDT
Are you still able to reproduce this issue with the latest tigervnc-server-0.0.91-0.12.fc11 ?
Comment 7 Gaetan Cambier 2009-09-04 06:10:01 EDT
In 16 bit depth :
Sep  4 12:06:08 Gaetan kernel: Xvnc[1280]: segfault at 0 ip 0820015b sp bfaee890 error 4 in Xvnc[8044000+23f000]

In 8 bit depth :
It's run normaly.

Version :
tigervnc-server-0.0.91-0.12.fc11.i586
Comment 8 Gaetan Cambier 2009-11-21 17:27:12 EST
Since a have instaled Fedora 12, all is ok