Bug 506314

Summary: Virt Manager does not show Proper RAM Usage
Product: [Fedora] Fedora Reporter: Hiemanshu <himanshu.sharmaa>
Component: kvmAssignee: Glauber Costa <gcosta>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 11CC: berrange, clalance, ehabkost, gcosta, markmc, quintela, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-19 06:53:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Hiemanshu 2009-06-16 12:39:46 EDT
Description of problem:
When using Fedora's inbuilt Virtual Mangaer for virtualization it does not show the proper percentage of RAM usage, i have one 1 GB ram allocated to a Windows XP VM and the ram usage is always 35% and if i change the RAM to 512MB virt-manager shows usage at 18%

Version-Release number of selected component (if applicable):
Virt-Manager 0.7.0

Steps to Reproduce:
1. Create a new VM with Windows XP a Guest.
2. Install from ISO/Disc
3. Check memory usage from Virt-Manager.
  
Actual results:
RAM usage constant.

Expected results:
RAM usage should vary with amount of RAM being used by Windows XP Guest.

Additional info:
Problem occurs if any Windows Guest is used with
Comment 1 Mark McLoughlin 2009-06-19 06:53:50 EDT
The 35% figure means that the guest is allocated 1GB of the hosts ~3GB of RAM.

It doesn't sound to me like there's a bug here.