Bug 506532

Summary: libvirt in verbose mode gives error about /sys not mounted when it is
Product: [Fedora] Fedora Reporter: Erik Jacobson <erikj>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: berrange, clalance, crobinso, itamar, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-17 12:46:28 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Erik Jacobson 2009-06-17 12:41:47 EDT
libvirtd is spewing the following incorrect error message at startup
in verbose mode:

libnuma: Warning: /sys not mounted or invalid. Assuming one node: No such file or directory

I did an strace to see what it was doing.  It appears it is trying to open 
a specific file under /sys that doesn't exist.  The error message shouldn't
say /sys is unmounted as that would lead to incorrect conclusions.  Instead,
it should say that the specific file under /sys wasn't found and that this
likely means it is a single node.  I think if we don't fix this, we'll get
confused users and complaints.  Indeed, I was starting in verbose mode to
track down an unrelated startup issue.

Indeed, /sys is mounted.  Further, node0 does exist.  It's only node 1 that
does not exist:

[root@cct201 init.d]# ls /sys/devices/system/node/node0/cpumap
/sys/devices/system/node/node0/cpumap
[root@cct201 init.d]# ls /sys/devices/system/node/node1/cpumap
ls: cannot access /sys/devices/system/node/node1/cpumap: No such file or directory


strace chunk:

open("/sys/devices/system/node/node0/cpumap", O_RDONLY) = 9
fstat(9, {st_mode=S_IFREG|0444, st_size=4096, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f301e76c000
read(9, "00000000,0000ffff\n"..., 4096) = 18
close(9)                                = 0
munmap(0x7f301e76c000, 4096)            = 0
open("/sys/devices/system/node/node1/cpumap", O_RDONLY) = -1 ENOENT (No such file or directory)
write(2, "libnuma: Warning: "..., 18libnuma: Warning: )   = 18
write(2, "/sys not mounted or invalid. Assu"..., 73/sys not mounted or invalid. Assuming one node: No such file or directory) = 73
write(2, "\n"..., 1


# rpm -q qemu-kvm libvirt virt-manager kernel
qemu-kvm-0.10.5-2.fc11.x86_64
libvirt-0.6.2-11.fc11.x86_64
virt-manager-0.7.0-5.fc11.x86_64
kernel-2.6.29.4-167.fc11.x86_64
Comment 1 Erik Jacobson 2009-06-17 12:46:28 EDT
whoops, already reported.  I did a bad bug search.

*** This bug has been marked as a duplicate of bug 499633 ***