Bug 507241

Summary: udevd-event[6713]: rename(/dev/capi/.udev-tmp, /dev/capi/) failed: Not a directory
Product: [Fedora] Fedora Reporter: Stefan Jensen <sjensen>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: harald
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: 141-4.fc11 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-07-22 17:44:33 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Stefan Jensen 2009-06-21 17:51:26 EDT
Description of problem:

I usally have to make a few changes to get my active AVM B1 Card to work. This
worked fine for me with the last 4 or 5 Fedora-Releases. 

But now with F11 i'm stuck with creating the correct devices with udev.

When I make my changes (see below) and start my capi, i get this error:

udevd-event[6713]: rename(/dev/capi/.udev-tmp, /dev/capi/) failed: Not a directory

Also, the devices got the wrong group and the symlink points to "/dev/capi/" and
not to "/dev/capi20". And the "/dev/capi" directory is empty. (i'm not sure, if this is correct, if capifs is loaded.)

The card seems to work so far, but i have not yet fully tested.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

1. install a avm-b1 pci
2. reboot or try starting capi
Actual results:

Devices get wrong Group and wrong symlink,
udev error showed up: rename(/dev/capi/.udev-tmp, /dev/capi/) failed: Not a directory

Expected results:

/dev/capi20 with correct perms and a symlink "faxCAPI" with no errors from udev.

Additional info:

$ cat /etc/udev/makedev.d/20-capi.nodes 


$ cat /etc/udev/rules.d/20-capi.rules

KERNEL=="capi", 		NAME="capi20", GROUP="dialout", MODE="0660", SYMLINK+="faxCAPI",
KERNEL=="capi*",		NAME="capi/%n", GROUP="dialout", MODE="0660"
KERNEL=="isdnctrl*",		NAME="%k", GROUP="dialout", MODE="0660"
KERNEL=="ippp*",		NAME="%k", GROUP="dialout", MODE="0660"
KERNEL=="isdn*",		NAME="%k", GROUP="dialout", MODE="0660"

$ ls -l /dev | grep capi

drwxr-xr-x. 2 root root           0 21. Jun 17:38 capi
crw-------. 1 root root     68,   0 21. Jun 17:38 capi20
lrwxrwxrwx. 1 root root           6 21. Jun 22:02 faxCAPI -> capi/

$ ls -l /dev | grep isdn

lrwxrwxrwx. 1 root root           9 21. Jun 17:38 isdnctrl -> isdnctrl0
crw-------. 1 root root     45,  64 21. Jun 17:38 isdnctrl0
crw-------. 1 root root     45, 255 21. Jun 17:38 isdninfo

$ ls -l /dev | grep ippp

crw-------. 1 root root     45, 128 21. Jun 17:38 ippp0
crw-------. 1 root root     45, 129 21. Jun 17:38 ippp1

$ ls -l /dev | grep ttyI

crw-rw----. 1 root uucp     43,   0 21. Jun 17:38 ttyI0
crw-rw----. 1 root uucp     43,   1 21. Jun 17:38 ttyI1

$ lspci | grep -i avm

04:0a.0 Network controller: AVM GmbH B1 ISDN (rev 01)

$ lsmod | grep capi

capidrv                27424  1 
isdn                  123648  5 capidrv
capi                   15328  0 
kernelcapi             36024  5 capidrv,b1pci,b1dma,b1,capi
capifs                  4848  2 capi

$ mount | grep capifs

capifs on /dev/capi type capifs (rw,mode=0666)

Full startup log of my capi:

==> messages <==
kernel: CAPI Subsystem Rev
kernel: capi20: Rev started up with major 68 (middleware+capifs)
udevd-event[7047]: rename(/dev/capi/.udev-tmp, /dev/capi/) failed: Not a directory
kernel: b1: revision
kernel: b1dma: revision
kernel: b1pci: PCI BIOS reports AVM-B1 V4 at i/o 0xe400, irq 23, mem 0xfebefc00
kernel: kcapi: Controller [001]: b1pciv4-e400 attached
kernel: b1pci: AVM B1 PCI V4 at i/o 0xe400, irq 23, mem 0xfebefc00, revision 4 (dma)
kernel: b1pci: revision
kernel: b1pciv4-e400: card 1 "B1" ready.
kernel: b1pciv4-e400: card 1 Protocol: DSS1
kernel: b1pciv4-e400: card 1 Linetype: point to multipoint
kernel: b1pciv4-e400: B1-card (3.10-02) now active
kernel: kcapi: card [001] "b1pciv4-e400" ready.
kernel: ISDN subsystem Rev: loaded
kernel: capidrv-1: now up (2 B channels)
kernel: capidrv-1: D2 trace enabled
kernel: capidrv: Rev loaded
isdnlog: isdnlog Version 4.71 starting
isdnlog: Holiday Version 1.10-Germany [12-Apr-1999] loaded [11 entries from /usr/share/isdn/holiday-de.dat]
isdnlog: Dest V1.01: File '/usr/share/isdn/dest.cdb' opened fine - Dest 1.0 int (+h) DE
isdnlog: Zone V1.25: Provider 0 File '/usr/share/isdn/zone-de-dtag.cdb' opened fine - V1.25 K2 C2 N256 T157147 O1 L5
isdnlog: Rates   Version 3.12 [27-Feb-2005 22:15:34] loaded [87 Providers, 0 skipped, 1325 Zones, 4755 Areas, 86 Services, 726 Comments, 10 eXceptions, 65 Redirects, 4298 Rates from /usr/share/isdn/rate-de.dat]
isdnlog: (ISDN subsystem with ISDN_MAX_CHANNELS > 16 detected, ioctl(IIOCNETGPN) is available)
isdnlog: isdn.conf:2 active channels, 0 MSN/SI entries
isdnlog: (Data versions: iprofd=0x06  net_cfg=0x06  /dev/isdninfo=0x01)
isdnlog: Everything is fine, isdnlog-4.71 is running in full featured mode.
Comment 1 Stefan Jensen 2009-06-24 11:02:40 EDT
Very strange, i simply swap the first 2 lines in my 20-capi.rules file:

KERNEL=="capi*",  NAME="capi/%n", GROUP="uucp", MODE="0660"
KERNEL=="capi",   NAME="capi20", GROUP="uucp", MODE="0660", SYMLINK+="faxCAPI"

and now i have a correct "capi20" Device, with correct permissions, symlink and also the "rename error" past away.

Now i have:

$ ls -l /dev/| grep capi

drwxr-xr-x 2 root root           0 24. Jun 12:52 capi
crw-rw---- 1 root uucp     68,   0 24. Jun 12:52 capi20
lrwxrwxrwx 1 root root           6 24. Jun 12:52 faxCAPI -> capi20

Which is great now. :-)

But it seems, that the other lines of the rule are not executed:

$ ls -l /dev/| grep isdn

lrwxrwxrwx 1 root root           9 24. Jun 12:52 isdnctrl -> isdnctrl0
crw------- 1 root root     45,  64 24. Jun 12:52 isdnctrl0
crw------- 1 root root     45, 255 24. Jun 12:52 isdninfo

still wrong permissions, any hints?

best regards
Comment 2 Harald Hoyer 2009-06-30 07:33:30 EDT
I will add the upstream rules 40-isdn.rules

SUBSYSTEM=="capi", KERNEL=="capi", NAME="capi20", GROUP="dialout"
SUBSYSTEM=="tty", KERNEL=="capi[0-9]*", NAME="capi/%n"
Comment 3 Fedora Update System 2009-06-30 08:05:41 EDT
udev-141-4.fc11 has been submitted as an update for Fedora 11.
Comment 4 Stefan Jensen 2009-06-30 16:17:30 EDT
Thanks, this works as expected.

The "default" owner/group "dialout" may confusing some people, because most (outdated) docs out there suggest "uucp" as owner/group.

Anyway, I'm pretty fine with "dailout", because it seems much more logical to me.

best regards
Comment 5 Fedora Update System 2009-07-02 01:45:41 EDT
udev-141-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7208
Comment 6 Fedora Update System 2009-07-22 17:44:15 EDT
udev-141-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.