This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 508042

Summary: It creates /dev/sdb but not /dev/sdb1
Product: [Fedora] Fedora Reporter: Davide Repetto <red>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: low    
Version: 11CC: harald
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-26 04:59:49 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
dmesg none

Description Davide Repetto 2009-06-25 06:52:00 EDT
Created attachment 349376 [details]
dmesg

Description of problem:
=======================
I have two internal HardDisks and this is what udev should create at boot time
sda   sda1  sda2  sda3  sdb   sdb1

Instead sdb1 is left out and all I get is:
sda   sda1  sda2  sda3  sdb

If I force a re-read of the partitions with "fdisk /dev/sdb"
followed by "w", the device (/dev/sdb1) gets created 
 

Version-Release number of selected component (if applicable):
=============================================================
udev-141-3.fc11
kernel-PAE-2.6.29.4-167.fc11


How reproducible:
=================
At every boot

Actual results:
===============
devices created: sda   sda1  sda2  sda3  sdb

Expected results:
Creation of: sda   sda1  sda2  sda3  sdb   sdb1

Additional info:
================

smolt profile: pub_ec93e9bf-828a-4127-b353-3933bfd5ba55

fdisk -l
========
Disco /dev/sda: 203.9 GB, 203928109056 byte

255 testine, 63 settori/tracce, 24792 cilindri
Unità = cilindri di 16065 * 512 = 8225280 byte
Identificativo disco: 0xe49ae49a

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1               1          26      208813+  83  Linux
/dev/sda2              27        4193    33471427+  83  Linux
/dev/sda3            4194       24792   165461467+  83  Linux

Disco /dev/sdb: 203.9 GB, 203928109056 byte

255 testine, 63 settori/tracce, 24792 cilindri
Unità = cilindri di 16065 * 512 = 8225280 byte
Identificativo disco: 0x38533853

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sdb1               1       24792   199141708+  83  Linux

Hard Disks are:
===============
1) ATA     	Maxtor 6Y200P0  	YAR4
2) ATA     	Maxtor 6Y200P0  	YAR4

dmesg
=====
included as an attachment
Comment 1 Harald Hoyer 2009-06-25 08:23:50 EDT
Please paste the output of:
# dmraid -tay -vvv
Comment 2 Davide Repetto 2009-06-25 11:54:36 EDT
"PDC metadata discovered" and sdb "added to RAID set"?
That's weird...

# dmraid -tay -vvv
WARN: locking /var/lock/dmraid/.lock
NOTICE: /dev/sdb: asr     discovering
NOTICE: /dev/sdb: ddf1    discovering
NOTICE: /dev/sdb: hpt37x  discovering
NOTICE: /dev/sdb: hpt45x  discovering
NOTICE: /dev/sdb: isw     discovering
NOTICE: /dev/sdb: jmicron discovering
NOTICE: /dev/sdb: lsi     discovering
NOTICE: /dev/sdb: nvidia  discovering
NOTICE: /dev/sdb: pdc     discovering
NOTICE: /dev/sdb: pdc metadata discovered
NOTICE: /dev/sdb: sil     discovering
NOTICE: /dev/sdb: via     discovering
NOTICE: /dev/sda: asr     discovering
NOTICE: /dev/sda: ddf1    discovering
NOTICE: /dev/sda: hpt37x  discovering
NOTICE: /dev/sda: hpt45x  discovering
NOTICE: /dev/sda: isw     discovering
NOTICE: /dev/sda: jmicron discovering
NOTICE: /dev/sda: lsi     discovering
NOTICE: /dev/sda: nvidia  discovering
NOTICE: /dev/sda: pdc     discovering
NOTICE: /dev/sda: sil     discovering
NOTICE: /dev/sda: via     discovering
NOTICE: added /dev/sdb to RAID set "pdc_eiejibjg"
pdc_eiejibjg: 0 0 linear /dev/sdb 0
INFO: Activating stripe raid set "pdc_eiejibjg"
WARN: unlocking /var/lock/dmraid/.lock
Comment 3 Harald Hoyer 2009-06-26 04:59:49 EDT
So it seems you have a raid signature on your drive.

See https://bugzilla.redhat.com/show_bug.cgi?id=504961#c13

*** This bug has been marked as a duplicate of bug 504961 ***