This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours

Bug 508258

Summary: qemu init script does nothing useful by default
Product: [Fedora] Fedora Reporter: Pilar Bravo <pbravo>
Component: qemuAssignee: Glauber Costa <gcosta>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dwmw2, gcosta, itamar, jaswinder, markmc, virt-maint
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-07 07:08:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 498969    

Description Pilar Bravo 2009-06-26 06:59:34 EDT
Description of problem:
qemu does not register handlers in Fedora 11. Same issue as described in 
https://bugzilla.redhat.com/show_bug.cgi?id=427825

Version-Release number of selected component (if applicable):
qemu-0.10.5-3.fc11

How reproducible:


Steps to Reproduce:
1. service qemu start
Registering binary handler for qemu applications
2. service qemu status
qemu binary format handlers are not registered.

  
Actual results:


Expected results:


Additional info:
Comment 1 Glauber Costa 2009-06-29 12:15:39 EDT
To the best of my knowledge, this is not a bug.

The init script search for a directory containing the runtime environment to the target architecture (gnemul). The qemu package does not provide it, so it comes as no surprise.

If you download gnemul and put it into /usr, it should work.

If there is disagreement on this, please reopen
Comment 2 Mark McLoughlin 2009-07-03 06:42:19 EDT
Let there be disagreement!

It's actually looking for e.g. /usr/qemu-${machine}, but that's a minor detail

Where does one download this runtime environment?

IMHO, we shouldn't be shipping an initscript if it doesn't do anything useful by default

Maybe the initscript should register the binary handler and let a missing /usr/qemu-${machine} be a runtime error? e.g. if the initscript runs at boot and you later download the runtime

Putting it on our target list for F-12
Comment 3 Glauber Costa 2009-07-06 10:06:15 EDT
yeah, our script in fact looks for /usr/qemu-${machine}.

I have no idea where to get it, since I don't use linux-user for years now.
Maybe people actually using can tell us about it?

Anyway, what I do know is that we have no way at all to ship it in Fedora

About your suggestion, it does nothing but postpone the error. And the way it works now, the user at least isn't misguided, since the binary handler is not present, so I slightly prefer the way it is.

But I'm fine with either approach.
Comment 4 Mark McLoughlin 2009-08-07 07:08:29 EDT
I'm dubious about the usefulness of this feature, but you're right - making it a runtime error doesn't help much.

Closing this as NOTABUG - the binary handlers will only work if there is a qemu-user runtime present

Where to get such a runtime is another question. We don't know where :-)
Comment 5 Glauber Costa 2009-08-07 07:18:59 EDT
It would be nice to broadly hear user's request if possible, but from my side,
I am 100 % okay with just removing it. I don't see any benefit it brings