Bug 508439

Summary: preupgrade has "Failed to fetch release info."
Product: [Fedora] Fedora Reporter: Matthew <emperor>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: gayleard, geekboy, jah, marceln, rzhou, trq, voinageo, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 566634 (view as bug list) Environment:
Last Closed: 2009-06-28 04:50:17 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Strace of preupgrade-cli
none
tcpdump capture file from the preupgrade run none

Description Matthew 2009-06-27 04:32:08 EDT
Created attachment 349636 [details]
Strace of preupgrade-cli

Description of problem:
preupgrade doesn't work

Version-Release number of selected component (if applicable):
preupgrade-1.1.0-1.fc11.noarch (saw same!? problem with fedora 9 version)

How reproducible:
Always, on two machines. Third F10 machine upgraded to F11 just fine with preupgrade.

Steps to Reproduce:
1.As root (or not) run preupgrade-cli or preupgrade
2.Always says "Failed to fetch release info."
3.
  
Actual results:
preupgrade-cli
/usr/lib/python2.6/site-packages/yum/__init__.py:181: UserWarning: Use .preconf instead of passing args to _getConfig
  warnings.warn('Use .preconf instead of passing args to _getConfig')
Loaded plugins: blacklist, presto, refresh-packagekit, upgrade-helper, whiteout
Loaded plugins: presto, refresh-packagekit, upgrade-helper
Failed to fetch release info.
This could be caused by a missing network connection or a bad mirror.

Expected results:


Additional info:
Failed Machines:
i386 F9
i386 F11

i386 F10 worked fine upgrading to

On both machines I'm browsing the net/pinging internet sites AND able to run yum updates just fine right before and after preupgrade-cli fails.
Comment 2 Matthew 2009-06-27 04:34:49 EDT
Just tested on x86_64 F11, same problem.
Comment 3 Marcel Nijenhof 2009-06-28 03:49:23 EDT
The problem is caused by a problem on the fedoraproject.org site.
Preupgrade uses the url "http://mirrors.fedoraproject.org/releases.txt" to
get the release information. But that url isn't working.

A short test:

$ wget http://mirrors.fedoraproject.org/releases.txt
--2009-06-28 09:43:30--  http://mirrors.fedoraproject.org/releases.txt
Resolving mirrors.fedoraproject.org... 152.46.7.222, 209.132.176.120, 66.35.62.166, ...
Connecting to mirrors.fedoraproject.org|152.46.7.222|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2009-06-28 09:43:30 ERROR 404: Not Found.

And the network dump during the run of preupgrade-cli:

No.     Time        Source                Destination           Protocol Info
      1 0.000000    192.168.103.2         192.168.103.1         DNS      Standard query AAAA mirrors.fedoraproject.org

Frame 1 (85 bytes on wire, 85 bytes captured)
Ethernet II, Src: 04:4b:80:80:80:03 (04:4b:80:80:80:03), Dst: CameoCom_67:3e:91 (00:40:f4:67:3e:91)
Internet Protocol, Src: 192.168.103.2 (192.168.103.2), Dst: 192.168.103.1 (192.168.103.1)
User Datagram Protocol, Src Port: 33969 (33969), Dst Port: domain (53)
Domain Name System (query)

No.     Time        Source                Destination           Protocol Info
      2 0.112096    192.168.103.1         192.168.103.2         DNS      Standard query response CNAME wildcard.fedoraproject.org

Frame 2 (159 bytes on wire, 159 bytes captured)
Ethernet II, Src: CameoCom_67:3e:91 (00:40:f4:67:3e:91), Dst: 04:4b:80:80:80:03 (04:4b:80:80:80:03)
Internet Protocol, Src: 192.168.103.1 (192.168.103.1), Dst: 192.168.103.2 (192.168.103.2)
User Datagram Protocol, Src Port: domain (53), Dst Port: 33969 (33969)
Domain Name System (response)

No.     Time        Source                Destination           Protocol Info
      3 0.112393    192.168.103.2         192.168.103.1         DNS      Standard query A mirrors.fedoraproject.org

Frame 3 (85 bytes on wire, 85 bytes captured)
Ethernet II, Src: 04:4b:80:80:80:03 (04:4b:80:80:80:03), Dst: CameoCom_67:3e:91 (00:40:f4:67:3e:91)
Internet Protocol, Src: 192.168.103.2 (192.168.103.2), Dst: 192.168.103.1 (192.168.103.1)
User Datagram Protocol, Src Port: 38360 (38360), Dst Port: domain (53)
Domain Name System (query)

No.     Time        Source                Destination           Protocol Info
      4 0.226046    192.168.103.1         192.168.103.2         DNS      Standard query response CNAME wildcard.fedoraproject.org A 80.239.156.215 A 152.46.7.222 A 209.132.176.120 A 66.35.62.166

Frame 4 (240 bytes on wire, 240 bytes captured)
Ethernet II, Src: CameoCom_67:3e:91 (00:40:f4:67:3e:91), Dst: 04:4b:80:80:80:03 (04:4b:80:80:80:03)
Internet Protocol, Src: 192.168.103.1 (192.168.103.1), Dst: 192.168.103.2 (192.168.103.2)
User Datagram Protocol, Src Port: domain (53), Dst Port: 38360 (38360)
Domain Name System (response)

No.     Time        Source                Destination           Protocol Info
      5 0.228908    192.168.103.2         80.239.156.215        TCP      42764 > http [SYN] Seq=0 Win=5840 Len=0 MSS=1460 TSV=4294823711 TSER=0 WS=7

Frame 5 (74 bytes on wire, 74 bytes captured)
Ethernet II, Src: 04:4b:80:80:80:03 (04:4b:80:80:80:03), Dst: CameoCom_67:3e:91 (00:40:f4:67:3e:91)
Internet Protocol, Src: 192.168.103.2 (192.168.103.2), Dst: 80.239.156.215 (80.239.156.215)
Transmission Control Protocol, Src Port: 42764 (42764), Dst Port: http (80), Seq: 0, Len: 0

No.     Time        Source                Destination           Protocol Info
      6 0.251470    80.239.156.215        192.168.103.2         TCP      http > 42764 [SYN, ACK] Seq=0 Ack=1 Win=5792 Len=0 MSS=1460 TSV=32052426 TSER=4294823711 WS=7

Frame 6 (74 bytes on wire, 74 bytes captured)
Ethernet II, Src: CameoCom_67:3e:91 (00:40:f4:67:3e:91), Dst: 04:4b:80:80:80:03 (04:4b:80:80:80:03)
Internet Protocol, Src: 80.239.156.215 (80.239.156.215), Dst: 192.168.103.2 (192.168.103.2)
Transmission Control Protocol, Src Port: http (80), Dst Port: 42764 (42764), Seq: 0, Ack: 1, Len: 0

No.     Time        Source                Destination           Protocol Info
      7 0.251570    192.168.103.2         80.239.156.215        TCP      42764 > http [ACK] Seq=1 Ack=1 Win=5888 Len=0 TSV=4294823733 TSER=32052426

Frame 7 (66 bytes on wire, 66 bytes captured)
Ethernet II, Src: 04:4b:80:80:80:03 (04:4b:80:80:80:03), Dst: CameoCom_67:3e:91 (00:40:f4:67:3e:91)
Internet Protocol, Src: 192.168.103.2 (192.168.103.2), Dst: 80.239.156.215 (80.239.156.215)
Transmission Control Protocol, Src Port: 42764 (42764), Dst Port: http (80), Seq: 1, Ack: 1, Len: 0

No.     Time        Source                Destination           Protocol Info
      8 0.251759    192.168.103.2         80.239.156.215        HTTP     GET /releases.txt HTTP/1.1 

Frame 8 (186 bytes on wire, 186 bytes captured)
Ethernet II, Src: 04:4b:80:80:80:03 (04:4b:80:80:80:03), Dst: CameoCom_67:3e:91 (00:40:f4:67:3e:91)
Internet Protocol, Src: 192.168.103.2 (192.168.103.2), Dst: 80.239.156.215 (80.239.156.215)
Transmission Control Protocol, Src Port: 42764 (42764), Dst Port: http (80), Seq: 1, Ack: 1, Len: 120
Hypertext Transfer Protocol
    GET /releases.txt HTTP/1.1\r\n
    Host: mirrors.fedoraproject.org\r\n
    Accept-Encoding: identity\r\n
    User-agent: urlgrabber/3.0.0\r\n
    \r\n

No.     Time        Source                Destination           Protocol Info
      9 0.275427    80.239.156.215        192.168.103.2         TCP      http > 42764 [ACK] Seq=1 Ack=121 Win=5888 Len=0 TSV=32052432 TSER=4294823734

Frame 9 (66 bytes on wire, 66 bytes captured)
Ethernet II, Src: CameoCom_67:3e:91 (00:40:f4:67:3e:91), Dst: 04:4b:80:80:80:03 (04:4b:80:80:80:03)
Internet Protocol, Src: 80.239.156.215 (80.239.156.215), Dst: 192.168.103.2 (192.168.103.2)
Transmission Control Protocol, Src Port: http (80), Dst Port: 42764 (42764), Seq: 1, Ack: 121, Len: 0

No.     Time        Source                Destination           Protocol Info
     10 0.276581    80.239.156.215        192.168.103.2         HTTP     HTTP/1.1 404 Not Found  (text/html)

Frame 10 (528 bytes on wire, 528 bytes captured)
Ethernet II, Src: CameoCom_67:3e:91 (00:40:f4:67:3e:91), Dst: 04:4b:80:80:80:03 (04:4b:80:80:80:03)
Internet Protocol, Src: 80.239.156.215 (80.239.156.215), Dst: 192.168.103.2 (192.168.103.2)
Transmission Control Protocol, Src Port: http (80), Dst Port: 42764 (42764), Seq: 1, Ack: 121, Len: 462
Hypertext Transfer Protocol
    HTTP/1.1 404 Not Found\r\n
    Date: Sun, 28 Jun 2009 07:32:35 GMT\r\n
    Server: Apache/2.2.3 (Red Hat)\r\n
    Content-Length: 301\r\n
    Content-Type: text/html; charset=iso-8859-1\r\n
    \r\n
Line-based text data: text/html

No.     Time        Source                Destination           Protocol Info
     11 0.276642    192.168.103.2         80.239.156.215        TCP      42764 > http [ACK] Seq=121 Ack=463 Win=6912 Len=0 TSV=4294823759 TSER=32052432

Frame 11 (66 bytes on wire, 66 bytes captured)
Ethernet II, Src: 04:4b:80:80:80:03 (04:4b:80:80:80:03), Dst: CameoCom_67:3e:91 (00:40:f4:67:3e:91)
Internet Protocol, Src: 192.168.103.2 (192.168.103.2), Dst: 80.239.156.215 (80.239.156.215)
Transmission Control Protocol, Src Port: 42764 (42764), Dst Port: http (80), Seq: 121, Ack: 463, Len: 0

No.     Time        Source                Destination           Protocol Info
     12 0.344058    192.168.103.2         80.239.156.215        TCP      42764 > http [RST, ACK] Seq=121 Ack=463 Win=6912 Len=0 TSV=4294823826 TSER=32052432

Frame 12 (66 bytes on wire, 66 bytes captured)
Ethernet II, Src: 04:4b:80:80:80:03 (04:4b:80:80:80:03), Dst: CameoCom_67:3e:91 (00:40:f4:67:3e:91)
Internet Protocol, Src: 192.168.103.2 (192.168.103.2), Dst: 80.239.156.215 (80.239.156.215)
Transmission Control Protocol, Src Port: 42764 (42764), Dst Port: http (80), Seq: 121, Ack: 463, Len: 0
Comment 4 Marcel Nijenhof 2009-06-28 03:52:38 EDT
Created attachment 349692 [details]
tcpdump capture file from the preupgrade run

This is a tcpdump/wireshark capture file from the preupgrade-cli run.

This capture shows that preupgrade tries to get the url
http://mirrors.fedoraproject.org/releases.txt and fails with a error
from the remote server.
Comment 5 Ricky Zhou 2009-06-28 04:50:17 EDT
My apologies, we recently rebuilt some servers and missed that file.  This should be fixed now, thanks for the report.
Comment 6 Marcel Nijenhof 2009-06-28 05:25:18 EDT
Confirm the solution.
Comment 7 Timothy Murphy 2009-07-01 15:21:39 EDT
I still get this error.

I don't see a file
http://mirrors.fedoraproject.org/releases.txt 
And I don't find
http://fedoraproject.org/releases.txt
either.

Am I misunderstanding in some way?
Comment 8 Scott 2010-02-18 20:45:03 EST
(In reply to comment #7)
> I still get this error.
> 
> I don't see a file
> http://mirrors.fedoraproject.org/releases.txt 
> And I don't find
> http://fedoraproject.org/releases.txt
> either.
> 
> Am I misunderstanding in some way?    

I don't know that you are. And as of this moment. http://fedoraproject.org/releases.txt still doesn't exist.
Comment 9 Scott 2010-02-18 20:54:46 EST
(In reply to comment #5)
> My apologies, we recently rebuilt some servers and missed that file.  This
> should be fixed now, thanks for the report.    

It's not fixed and the quote from you above is from June 2009....
Comment 10 jah 2010-04-25 07:17:19 EDT
Whether this is pertinent or not, I do not know, but I had this same problem:
"Failed to fetch release info."

the problem went away when I erased yum-fastestmirror and preupgrade is currently "downloading package metadata" (from the slowest ever mirror).
Comment 11 George Voina 2010-11-24 08:36:11 EST
This is still not fixed with current version preupgrade-1.1.5-1.fc11.
  I still have a machine with Fedora 11 and after 1.5 years this error is still there.
  Why was this closed ? 
  Currently it is impossible to use preupgrade from Fedora 11 and the support for FC11 is already stopped. Very bad people :( giving Linux a bad name because of this small stupid bugs.