Bug 50857

Summary: Compaq 1655 (ES1868) sound card failure
Product: [Retired] Red Hat Linux Reporter: Bobby Brinkley <bbrinkle>
Component: sndconfigAssignee: Bill Nottingham <notting>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: billc, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-01-21 22:18:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bobby Brinkley 2001-08-03 23:29:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
Cannot configure my ES1868 soundcard on my Compaq 1655 laptop.

How reproducible:

Steps to Reproduce:
1.start sndconfig
2.choose ES1868 AudioDrive
3.Set I/O Port = 0x220  IRQ = 7 DMA = 0  MPU I/O = 0x330
  (actually any combination fails)

Actual Results:  displays "An error occured opening /dev/audio". 

Expected Results:  correct soundcard configuration

Additional info:

I have tried several drivers (i.e. Sound Blasters) to no avail.  I have 
this same problem on RH 7.1 before I loaded roswell (both were fresh 
installs).  I have no /etc/isapnp.conf file and no /proc/isapnp file.  
Below are my /etc/modules.conf and sound file

alias parport_lowlevel parport_pc
alias sound-slot-0 sb
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L 
>/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 
2>&1 || :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options sb io=0x220 irq=7 dma=0 mpu_io=0x330

# There should be no spaces at the start of a line
# or around the '=' sign

Comment 1 Bill Nottingham 2001-08-06 00:30:16 UTC
What is the card set to in the BIOS?

Comment 2 Bobby Brinkley 2001-08-06 01:49:20 UTC
My soundcard configuration in the BIOS is:

Base I/O address :  220-22F
Interrupt:          IRQ 5
DMA channel:        DMA 1
DMA channel:        DMA 0
FM I/O address      388-38B
MPU I/O address     330-331

I have also tried all possible combinations using all values.

Comment 3 Bill Crawford 2001-08-08 11:55:45 UTC
If PnP support is enabled in the kernel, then a card such as this *should* work
"out of the box" by just loading the driver module.  At least it Works For
Me[tm] with a non-PnP SB at work, and a PnP ES1869 at home, and it's the same
driver (sb).

All I have in modules.conf is:

alias sound-slot-0 sb
alias synth0 opl3
options opl3 io=0x0388

The synth driver does seem to need I/O specified, but the SB driver picks up
without any problem.

Comment 4 Bobby Brinkley 2001-08-08 12:17:17 UTC
I will try changing my modules.conf; however, I did not have any problems with 
this in any pre RH7.1 distros.  It worked "out of the box" in 7.0 and 6.2.  
This is driving me crazy.

Comment 5 Bobby Brinkley 2001-08-19 16:01:21 UTC
I manually changed my modules.conf from IRQ7 to IRQ5 and it now works.  The 
problem is that sndconfig fails when trying to use the proper IRQ which is 5.  
Why is this, and can this be fixed in the next version of sndconfig?

Comment 6 Bill Nottingham 2001-08-20 01:55:31 UTC
What do you get if you cat /proc/isapnp?

Comment 7 Bill Nottingham 2001-08-20 01:56:36 UTC
Oops, never mind.

sndconfig *should* work fine if you enter those settings; do you have any
sound apps running when you start sndconfig?

Comment 8 Bobby Brinkley 2001-08-20 11:20:05 UTC
Not that I am aware of., In fact no, because I booted without graphical bootup 
and tried sndconfig and it still gave the previous results.

Comment 9 Bill Nottingham 2005-01-21 22:18:26 UTC
sndconfig is no longer developed, and this release has reached end-of-life.
Closing out old bugs.