Bug 508823

Summary: exo-mount doesn't mount vfat volumes with utf8 option
Product: [Fedora] Fedora Reporter: Kevin Fenzi <kevin>
Component: exoAssignee: Kevin Fenzi <kevin>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: cwickert, kevin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.3.101-4.fc11 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-29 10:21:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kevin Fenzi 2009-06-30 01:33:07 EDT
From upstream bug:

http://bugzilla.xfce.org/show_bug.cgi?id=2891

and discussed at: 

http://forums.fedoraforum.org/showthread.php?t=225188

We should look at applying the upstream patch, or possibly some less invasive patch.
Comment 1 Kevin Fenzi 2009-07-19 14:19:46 EDT
This is a somewhat messy issue. ;( 

I will whip up a scratch build of the patch in the upstream report and see how well it works and what we want to do here. Sorry for the delay.
Comment 2 Kevin Fenzi 2009-07-19 14:32:35 EDT
Here's a scratch build with the upstream patch applied: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=1485415
Comment 3 Christoph Wickert 2009-09-09 22:45:38 EDT
Hmmm, I don't really like this, way to invasive. How about something like
http://patches.ubuntu.com/e/exo/extracted/xubuntu-default-mount-options.patch
Comment 4 Kevin Fenzi 2009-09-09 23:42:15 EDT
Yeah, that one would be fine for me too... I'm not sure how big a problem this is, I really have only run into one report of it. ;(
Comment 5 Christoph Wickert 2009-09-10 01:18:16 EDT
Most likely because in the US no one really need to care about UTF-8, but here in Europe it's a problem. I had complainants in #fedora-de and fedoraforum.de.

I have built exo-0.3.101-4 with the Ubuntu patch.
http://koji.fedoraproject.org/koji/buildinfo?buildID=131377
Works fine for me and at least one other person.
Comment 6 Fedora Update System 2009-09-10 01:43:34 EDT
exo-0.3.101-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/exo-0.3.101-4.fc11
Comment 7 Fedora Update System 2009-09-11 19:38:53 EDT
exo-0.3.101-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update exo'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9526
Comment 8 Fedora Update System 2009-09-29 10:21:51 EDT
exo-0.3.101-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.