This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 509311

Summary: Preupgrade F10->F11 aborts with "Operation not supported"
Product: [Fedora] Fedora Reporter: John van der Vuurst <johnvandervuurst>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 10CC: johnvandervuurst, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: http://www.johnvandervuurst.nl
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-12-18 04:36:40 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
additional information, includes package list, hardware info, kernel version etc. none

Description John van der Vuurst 2009-07-02 02:57:17 EDT
Created attachment 350248 [details]
additional information, includes package list, hardware info, kernel version etc.

Description of problem:

When executing a distribution upgrade from F10 to F11 as indicated by the update wizard of packagekit, it fails in the generating metadata step with an OSError (Error number 95) Operation not supported.

---Dump of last run of preupgrade.

/usr/lib/python2.5/site-packages/yum/__init__.py:181: UserWarning: Use .preconf instead of passing args to _getConfig
  warnings.warn('Use .preconf instead of passing args to _getConfig')
Loaded plugins: blacklist, fastestmirror, fedorakmod, kernel-module, refresh-
              : packagekit, refresh-updatesd, rpm-warm-cache, whiteout
Detected in-progress upgrade to Fedora 11 (Leonidas)
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-11&arch=$basearch
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-11&arch=i386
Loading mirror speeds from cached hostfile
 * fedora: fedora.inode.at
 * livna: rpm.livna.org
 * rpmfusion-free: fedora.tu-chemnitz.de
 * rpmfusion-free-updates: fedora.tu-chemnitz.de
 * rpmfusion-nonfree: fedora.tu-chemnitz.de
 * rpmfusion-nonfree-updates: fedora.tu-chemnitz.de
 * updates: fedora.inode.at
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/11/Fedora/$basearch/os
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/11/Fedora/i386/os
Checking for new repos for mirrors
 * preupgrade-main: fedora.inode.at
preupgrade-fedora (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-11&arch=i386
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-11&arch=i386
Checking for new repos for mirrors
preupgrade-livna (mirrorlist) 
  url: http://rpm.livna.org/mirrorlist
  now: http://rpm.livna.org/mirrorlist
Checking for new repos for mirrors
 * preupgrade-fedora: fedora.inode.at
Can't set up new repo preupgrade-livna - removing
preupgrade-rpmfusion-free (mirrorlist) 
  url: http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-11&arch=i386
  now: http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-11&arch=i386
Checking for new repos for mirrors
preupgrade-rpmfusion-free-updates (mirrorlist) 
  url: http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-updates-released-11&arch=i386
  now: http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-updates-released-11&arch=i386
Checking for new repos for mirrors
 * preupgrade-rpmfusion-free: fedora.tu-chemnitz.de
preupgrade-rpmfusion-nonfree (mirrorlist) 
  url: http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-11&arch=i386
  now: http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-11&arch=i386
Checking for new repos for mirrors
 * preupgrade-rpmfusion-free-updates: fedora.tu-chemnitz.de
preupgrade-rpmfusion-nonfree-updates (mirrorlist) 
  url: http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-updates-released-11&arch=i386
  now: http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-updates-released-11&arch=i386
Checking for new repos for mirrors
 * preupgrade-rpmfusion-nonfree: fedora.tu-chemnitz.de
preupgrade-updates (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f11&arch=i386
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f11&arch=i386
Checking for new repos for mirrors
 * preupgrade-rpmfusion-nonfree-updates: fedora.tu-chemnitz.de
Fetched treeinfo from http://ftp.nluug.nl/pub/os/Linux/distr/fedora/linux/releases/11/Fedora/i386/os//.treeinfo
treeinfo timestamp: Wed Jun  3 00:01:41 2009
/boot/upgrade/vmlinuz checksum OK
/boot/upgrade/initrd.img checksum OK
/boot/upgrade/install.img checksum OK
Checking for new repos for mirrors
 * preupgrade-updates: fedora.inode.at
VirtualBox-2.2.4_47978_fedora9-1.i386 from installed has depsolving problems
  --> Missing Dependency: libcrypto.so.7 is needed by package VirtualBox-2.2.4_47978_fedora9-1.i386 (installed)
google-gadgets-0.10.5-7.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libltdl.so.3 is needed by package google-gadgets-0.10.5-7.fc10.i386 (installed)
perl-Crypt-OpenSSL-DSA-0.13-12.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libssl.so.7 is needed by package perl-Crypt-OpenSSL-DSA-0.13-12.fc10.i386 (installed)
perl-Crypt-OpenSSL-DSA-0.13-12.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libcrypto.so.7 is needed by package perl-Crypt-OpenSSL-DSA-0.13-12.fc10.i386 (installed)
VirtualBox-2.2.4_47978_fedora9-1.i386 from installed has depsolving problems
  --> Missing Dependency: libpython2.5.so.1.0 is needed by package VirtualBox-2.2.4_47978_fedora9-1.i386 (installed)
google-gadgets-qt-0.10.5-7.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libltdl.so.3 is needed by package google-gadgets-qt-0.10.5-7.fc10.i386 (installed)
bzr-1.15.1-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package bzr-1.15.1-1.fc10.i386 (installed)
bzr-1.15.1-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libpython2.5.so.1.0 is needed by package bzr-1.15.1-1.fc10.i386 (installed)
Excluding to be erased: kernel-2.6.27.19-170.2.35.fc10.i686
Excluding to be erased: kernel-2.6.27.15-170.2.24.fc10.i686
Excluding to be erased: kernel-2.6.27.21-170.2.56.fc10.i686
VirtualBox-2.2.4_47978_fedora9-1.i386 from installed has depsolving problems
  --> Missing Dependency: libcrypto.so.7 is needed by package VirtualBox-2.2.4_47978_fedora9-1.i386 (installed)
google-gadgets-0.10.5-7.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libltdl.so.3 is needed by package google-gadgets-0.10.5-7.fc10.i386 (installed)
perl-Crypt-OpenSSL-DSA-0.13-12.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libssl.so.7 is needed by package perl-Crypt-OpenSSL-DSA-0.13-12.fc10.i386 (installed)
perl-Crypt-OpenSSL-DSA-0.13-12.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libcrypto.so.7 is needed by package perl-Crypt-OpenSSL-DSA-0.13-12.fc10.i386 (installed)
VirtualBox-2.2.4_47978_fedora9-1.i386 from installed has depsolving problems
  --> Missing Dependency: libpython2.5.so.1.0 is needed by package VirtualBox-2.2.4_47978_fedora9-1.i386 (installed)
google-gadgets-qt-0.10.5-7.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libltdl.so.3 is needed by package google-gadgets-qt-0.10.5-7.fc10.i386 (installed)
bzr-1.15.1-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package bzr-1.15.1-1.fc10.i386 (installed)
bzr-1.15.1-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libpython2.5.so.1.0 is needed by package bzr-1.15.1-1.fc10.i386 (installed)
Downloading 10.5MB
Available disk space for /var/cache/yum/preupgrade: 159.4GB
Upgrade requires 500.0MB
Available disk space for /usr: 3.6GB
Generating metadata for preupgrade repo
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 766, in <module>
    widgets = PreUpgradeGtk()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 374, in __init__
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 257, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 545, in main_preupgrade
    callback=MDGenCallback(pbar=self.progress))
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 650, in generate_repo
    self.gather_downloaded_packages(dir)
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 664, in gather_downloaded_packages
    os.link(os.path.join(fullpkgdir,p),newfile)
OSError: [Errno 95] Operation not supported

---------------------------------------------------------

Version-Release number of selected component (if applicable):

PackageKit:

PackageKit-0.3.16-1.fc10.i386
PackageKit-glib-0.3.16-1.fc10.i386
PackageKit-gstreamer-plugin-0.3.16-1.fc10.i386
PackageKit-qt-0.3.16-1.fc10.i386
PackageKit-udev-helper-0.3.16-1.fc10.i386
PackageKit-yum-0.3.16-1.fc10.i386
PackageKit-yum-plugin-0.3.16-1.fc10.i386

preupdate:

preupgrade-1.1.0-1.fc10.noarch

Yum:

yum-3.2.23-3.fc10.noarch
yum-allowdowngrade-1.1.19-1.fc10.noarch
yum-cron-0.8.3-1.fc10.noarch
yum-fedorakmod-1.1.19-1.fc10.noarch
yum-kernel-module-1.1.19-1.fc10.noarch
yum-metadata-parser-1.1.2-10.fc10.i386
yum-plugin-aliases-1.1.22-1.fc10.noarch
yum-plugin-changelog-1.1.22-1.fc10.noarch
yum-plugin-downloadonly-1.1.22-1.fc10.noarch
yum-plugin-fastestmirror-1.1.22-1.fc10.noarch
yum-plugin-filter-data-1.1.22-1.fc10.noarch
yum-plugin-keys-1.1.22-1.fc10.noarch
yum-plugin-list-data-1.1.22-1.fc10.noarch
yum-plugin-refresh-updatesd-1.1.22-1.fc10.noarch
yum-plugin-rpm-warm-cache-1.1.22-1.fc10.noarch
yum-plugin-verify-1.1.22-1.fc10.noarch
yum-updatesd-0.9-1.fc9.noarch
yum-utils-1.1.22-1.fc10.noarch
yumex-2.0.5-3.fc10.noarch

Complete installed packages list in additionalInfo.tar.gz attached.

How reproducible:

Have tried it twice, with same result.

Steps to Reproduce:
1. start upgrade process, either via update wizard, or by running pk-upgrade-distro.sh
2. wait a couple of hours
3. see that it failed.
  
Actual results:

Failed update, no packages have been upgraded

Expected results:

Being upgraded to fedora 11.

Additional info:

See additionalInfo.tar.gz attached.
Comment 1 Will Woods 2009-07-02 11:16:46 EDT
    os.link(os.path.join(fullpkgdir,p),newfile)
OSError: [Errno 95] Operation not supported

This seems to indicate that whatever filesystem /var/cache/yum is on doesn't support hardlinks. What filesystem are you using there?
Comment 2 John van der Vuurst 2009-07-06 05:25:30 EDT
Ah, that could explain a bit. Since the upgrade needed to load a lot of packages, the /var filesystem ran full. I then moved the yum-tree of /var/cache/yum to an external filesystem (USB), and create a symbolic link /var/cache/yum to it.

I will move it back, and retry the upgrade.

Thanks for your help.
Comment 3 Bug Zapper 2009-11-18 07:08:33 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2009-12-18 04:36:40 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.