Bug 509751

Summary: completion doesn't work correctly with quoted names
Product: [Fedora] Fedora Reporter: Joel <jdy>
Component: bash-completionAssignee: Ville Skyttä <ville.skytta>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: jdy, rrakus, sheltren, ville.skytta
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.2-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-22 21:34:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joel 2009-07-05 19:32:22 UTC
Description of problem:

When using tab completion for media files with mplayer, they won't complete.  Tab does nothing

Version-Release number of selected component (if applicable):

bash-completion.noarch 1:1.0-2.fc11 


How reproducible:

mkdir test
touch "a b c.mpg"
touch "l.avi"
type:
mplayer "a[tab]

and it completes properly

mplayer "a[space][tab]

and it does not complete and just lists:
a b c.mpg l.avi

mplayer "a[space]b[tab]

and nothing is displayed and just beeps.
  
Expected results:

All of the above [tab] presses should have resulted in a completed filename.

Comment 1 Ville Skyttä 2009-07-07 18:33:49 UTC
Is there a "cd test" missing in your reproducer?  Assuming so.  Completing using quotes like that doesn't work at all in F-10 (I guess bash < 4), and I'm a bit surprised that it works in the first place with later versions - it does work in a Rawhide mock chroot for me the expected way.  A workaround for F-11 seems to be not to use quotes at all, just do "mplayer a[tab]".

So, this seems to be something that happens in F-11 only.  bash-completion is practically the same in both so I suppose something else causes it.  bash maintainers, any ideas?


Oh, and this doesn't seem to have anything to do with mplayer, it's reproducible using for example python too:

mkdir test
cd test
touch "a b c.py" "l.py"

python "a<TAB>
--> completes OK to 'python "a b c.py"'

python "a <TAB>
--> does not complete, 2nd <TAB> lists "a b c.py  l.py" as possible completions

python "a b<TAB>
--> does not complete at all

Comment 2 Joel 2009-07-07 18:45:01 UTC
> Is there a "cd test" missing in your reproducer?  Assuming so.

Yes...you're right.  My bad.

> Completing using quotes like that doesn't work at all in F-10 
> (I guess bash < 4)

I upgraded from F-9 directly to F-11.  It worked perfectly in F-9.

Thanks for generalizing the test case.

Joel

Comment 3 Ville Skyttä 2009-07-07 18:53:42 UTC
I don't have access to a F-9 box, but it seems to work on F-8 as well, so F-10 and F-11 seem to be affected, possibly in different ways.

Comment 4 Joel 2009-08-24 16:25:21 UTC
Any word on this one?

Comment 5 Ville Skyttä 2009-08-26 15:43:33 UTC
Not yet.

Comment 7 Fedora Update System 2010-06-20 12:25:19 UTC
bash-completion-1.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bash-completion-1.2-1.fc13

Comment 8 Fedora Update System 2010-07-01 18:59:44 UTC
bash-completion-1.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.