Bug 51

Summary: Installer seems to fail to set any partitions bootable
Product: [Retired] Red Hat Linux Reporter: Preston Brown <pbrown>
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: msw
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-13 21:58:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Preston Brown 1998-11-12 11:42:33 UTC
After a server install, the installer seems to fail to set
any partitions bootable.  Some computers need to have a
partition marked bootable to boot. :)  This failure
necessitates booting from floppy, entering fdisk, and
setting the first partition bootable before the system can
be fully usable.

Comment 1 David Lawrence 1998-11-19 13:51:59 UTC
I was able to install to a machine that currently had NT 4.0 installed
on the entire hard drive. I ran the server installation and it
correctly created the partitions and was able to boot up normally.
Please let use know what the prior configuration was on your system
was before you attemmpted the server installation.

Comment 2 Edward Schlunder 1998-12-05 00:44:59 UTC
No, the problem is with machihnes that have absolutely nothing on them
and you want to install Linux all by itself on the machine. In this
case, if you use Disk Druid to create your Linux partitions, the first
partition is never marked "active" and thus LILO you can't boot after
the install.

If you are installing Red Hat 5.2 on a machine with some other OS
already on it, chances are you will already have a partition marked
active and thus you'll never see this problem.

Comment 3 Preston Brown 1998-12-05 01:46:59 UTC
matt/dave: I believe this is still a very valid bug.  Please take the
bootable flag off all partitions on a drive, and then wipe the
partitions, and see if an install works correctly.

Comment 4 David Lawrence 1998-12-07 21:30:59 UTC
I have not been able to replicate this problem in the test lab. I
low-leveled the first few tracks of the hard disk as to emulate a
brand new hard disk with no information on it and the server install
still worked properly.

Comment 5 dank 1999-03-10 15:44:59 UTC
This has become a very public bug; see Jerry Pournelle's column
in this month's resurrected Byte,
http://www.byte.com/columns/chaosmanor/1999/030199a.html

At the first installfest I attended, one user was stymied
by this bug for about an hour, until we realized the installer
had failed to mark anything bootable.

In neither of the above cases was it a server install.
I think it can happen regardless of workstation, custom,
or server install.

If you can't reproduce it, email me, and I'll try to come
up with a recipe.

Comment 6 Preston Brown 1999-03-10 16:46:59 UTC
this bug is getting fixed in our next distribution.

Comment 7 Matt Wilson 1999-03-13 21:58:59 UTC
Fixed in the next release.