This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 511175

Summary: PHP SOAP request generated with empty tag for NULL variables
Product: Red Hat Enterprise Linux 5 Reporter: Jatin Nansi <jnansi>
Component: phpAssignee: Joe Orton <jorton>
Status: CLOSED ERRATA QA Contact: BaseOS QE <qe-baseos-auto>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.3CC: cward, tao
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-30 04:24:30 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 505355    
Bug Blocks:    
Attachments:
Description Flags
proposed patch none

Description Jatin Nansi 2009-07-13 22:17:18 EDT
Description of problem:

Base OS: RHEL-5.3

The test case requires patch from BZ #505355 to be applied since it will crash otherwise.

When PHP SOAP request generated from a class with a null member variable, it generates an empty tag for the null member variable. It should not be including that variable in the request. Upstream bug report for this:

http://bugs.php.net/bug.php?id=41004

Attached reproducer code.

Version-Release number of selected component (if applicable):
php-5.1.6-23.2.el5_3

How reproducible:
Always.

Steps to Reproduce:

$ php OrderCheckService.wsdl

Actual results:
Request as seen in actual.txt

Expected results:
Request as seen in expected.txt

Additional info:

The fix is in upstream cvs:

http://cvs.php.net/viewvc.cgi/php-src/ext/soap/php_encoding.c?r1=1.103.2.21.2.30&r2=1.103.2.21.2.31

From Siddesh Poyrekar (GSS production support):
I have attached patch adapted to RHEL-5. I can confirm that it resolves the issue. I've given a test package to the customer as well. Customer has confirmed that the patch resolves the issue.
Comment 1 Jatin Nansi 2009-07-13 22:19:21 EDT
The reproducer step should actually be:
$ php OrderCheckService.php
Comment 3 Jatin Nansi 2009-07-13 22:22:31 EDT
Created attachment 351546 [details]
proposed patch
Comment 6 Joe Orton 2009-12-16 07:42:23 EST
I've made test packages available which should fix this issue.  These
packages are unsupported, have not been through the standard Red Hat
QA process, and are not recommended for use on production systems.

   http://people.redhat.com/~jorton/Tikanga-php/

Use of these packages may prevent you from (automatically) upgrading
to any asynchronous security errata which are issued before the
release of RHEL 5.5 due to version mismatches.

Please record any feedback on use of these test packages (positive or
negative!) on this bug report.
Comment 8 Chris Ward 2010-02-11 05:25:10 EST
~~ Attention Customers and Partners - RHEL 5.5 Beta is now available on RHN ~~

RHEL 5.5 Beta has been released! There should be a fix present in this 
release that addresses your request. Please test and report back results 
here, by March 3rd 2010 (2010-03-03) or sooner.

Upon successful verification of this request, post your results and update 
the Verified field in Bugzilla with the appropriate value.

If you encounter any issues while testing, please describe them and set 
this bug into NEED_INFO. If you encounter new defects or have additional 
patch(es) to request for inclusion, please clone this bug per each request
and escalate through your support representative.
Comment 11 errata-xmlrpc 2010-03-30 04:24:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0241.html