Bug 513801

Summary: Sound fails after varying time intervals during sound or video playback
Product: [Fedora] Fedora Reporter: Trevor Christian <doubleOTeC>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 11CC: lkundrak, lpoetter, sergio.lietti, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-07-28 09:20:05 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Trevor Christian 2009-07-25 20:51:11 EDT
Description of problem:
Sound playback stops while watching movies or playing sounds on the computer. At this point no sound is produced. After a while a cracking sound comes through the speakers and subsequently sound such as computer alerts etc are once again audible. 

Version-Release number of selected component (if applicable):
pulseaudio...0.9.15

How reproducible:
Play sound of video file
  
Actual results:
Sound cuts off after a short period of time - Thus far time has not exceeded 2-3 minutes.

Expected results:
Continued and continuous playback.

Additional info:
This behaviour was first noticed after an update.
Excerpts from the /var/log/yum.log and the /var/log/messages can be seen at https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4648
Comment 1 Lennart Poettering 2009-07-27 19:23:06 EDT
Sounds as if PA goes away due to CPU overload caused by a driver bug in snd_pcm_avail().

Is there anything listed regarding pulseaudio in syslog when this happens?
Comment 2 Trevor Christian 2009-07-27 19:48:23 EDT
Yes...
Excerpts of log filles...
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4648
.
.
.
An excerpt from /var/log/messages follows:
Jul 25 20:15:58 TeCHPLT kernel: gvfs-gdu-volume[2681]: segfault at c ip 006fccaa sp bfed3530 error 4 in libgdu.so.0.0.0[6f4000+22000]
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-sink.c: Increasing wakeup watermark to 30.00 ms
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294960240 bytes (22369584 ms).
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: snd_pcm_dump():
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: Its setup is:
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: stream : PLAYBACK
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: access : MMAP_INTERLEAVED
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: format : S16_LE
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: subformat : STD
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: channels : 2
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: rate : 48000
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: exact rate : 48000 (48000/1)
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: msbits : 16
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: buffer_size : 16384
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: period_size : 16384
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: period_time : 341333
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: tstamp_mode : ENABLE
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: period_step : 1
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: avail_min : 16384
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: period_event : 0
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: start_threshold : -1
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: stop_threshold : 1073741824
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: silence_threshold: 0
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: silence_size : 0
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: boundary : 1073741824
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: appl_ptr : 5719783
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: hw_ptr : 5701635
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 412780 bytes (2149 ms).
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 25 20:20:41 TeCHPLT pulseaudio[2486]: alsa-util.c: snd_pcm_dump():
                                                                                                                                                                                              6605,1 99%
Comment 3 Lennart Poettering 2009-07-28 09:20:05 EDT
snd_pcm_avail() returned a value that is exceptionally large: 4294960240 bytes (22369584 ms).

Yes, your sound driver is broken and is at fault here.

*** This bug has been marked as a duplicate of bug 506075 ***