Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 51389

Summary: Test install failed
Product: [Retired] Red Hat Linux Reporter: Peter Bowen <pzbowen+rhbeta>
Component: up2dateAssignee: Adrian Likins <alikins>
Status: CLOSED DUPLICATE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-08-10 23:05:00 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Peter Bowen 2001-08-09 22:10:21 EDT
When trying to use up2date, I got the following warning:

Test install failed failed because of package conflicts:
package Gtk-Perl-0.7008-ximian.1 (which is newer than Gtk-Perl-0.7008-1) is
already installed

If the version on my system is newer than the version that RHN has, then I
should not have been offered the package to upgrade.
Comment 1 Peter Bowen 2001-08-09 23:04:28 EDT
Steps to reproduce:

1) Install Red Hat Linux 6.2
2) Update to the latest errata _except_ only update to RPM v3.0.5  You won't be
able to install the ucd-snmp update, and will only be able to update to
up2date-2.1.x, the 2nd to last gnorpm updates, and a couple of others.
3) Install Ximian GNOME 1.4, including packages from the Ximian Preview Channel
4) Upgrade to Fairfax beta3
5) Run rhn_register and register the system
6) Run up2date, choose select all packages and try to upgrade
7) See the error message :)
Comment 2 Glen Foster 2001-08-10 16:03:43 EDT
This defect is considered MUST-FIX for Fairfax.
Comment 3 Adrian Likins 2001-08-10 16:40:24 EDT
our gnome packages have a higher epoch than ximians.
Comment 4 Cristian Gafton 2001-08-10 16:57:44 EDT
Assigned to the owner of component
Comment 5 Peter Bowen 2001-08-10 23:04:55 EDT
After a little more testing, I can make this error occur when I only select
Gtk-Perl or eel.  I could probably recreate this error with several other packages.

Neither the Gtk-Perl nor the eel package from Ximian, nor the ones from RHL
Rawhide, have an epoch, sorry Adrian :/
Comment 6 Peter Bowen 2001-08-16 12:06:55 EDT

*** This bug has been marked as a duplicate of 51760 ***