Bug 514828

Summary: dhclient complains of syntax errors in lease file
Product: [Fedora] Fedora Reporter: Christopher Beland <beland>
Component: dhcpAssignee: Jiri Popelka <jpopelka>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 12CC: mads, sassmann, sergeobelare, udovdh
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: dhcp-4.1.1-18.P1.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 631071 (view as bug list) Environment:
Last Closed: 2010-09-13 11:02:43 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Excerpt from /var/log/messages
none
Current contents of /var/lib/dhclient/dhclient-8a78b26a-e12c-49e1-8c83-b2b70d7512aa-wlan0.lease none

Description Christopher Beland 2009-07-30 18:45:33 EDT
The following log output was generated while waking up from a suspend.  More comprehensive log excerpt is attached.

dhclient: Internet Systems Consortium DHCP Client 4.1.0
dhclient: Copyright 2004-2008 Internet Systems Consortium.
dhclient: All rights reserved.
dhclient: For info, please visit http://www.isc.org/sw/dhcp/
dhclient: 
dhclient: /var/lib/dhclient/dhclient-8a78b26a-e12c-49e1-8c83-b2b70d7512aa-wlan0.lease line 12: semicolon expected.
dhclient:   rebind 
dhclient:    ^
dhclient: /var/lib/dhclient/dhclient-8a78b26a-e12c-49e1-8c83-b2b70d7512aa-wlan0.lease line 14: semicolon expected.
dhclient: }
dhclient:  ^
dhclient: /var/lib/dhclient/dhclient-8a78b26a-e12c-49e1-8c83-b2b70d7512aa-wlan0.lease line 14: unterminated lease declaration.
dhclient: }
dhclient: 

Version: dhclient-4.1.0-23.fc11.i586
Comment 1 Christopher Beland 2009-07-30 18:46:59 EDT
Created attachment 355743 [details]
Excerpt from /var/log/messages
Comment 2 Christopher Beland 2009-07-30 18:47:30 EDT
Created attachment 355744 [details]
Current contents of /var/lib/dhclient/dhclient-8a78b26a-e12c-49e1-8c83-b2b70d7512aa-wlan0.lease
Comment 3 David Cantrell 2009-08-05 00:04:32 EDT
Looks like ISC has updated the dhcp file parser to more closely fall in line with BIND's, but they haven't fully updated the code to write out files in the right format.

I've created a patch for dhclient for this issue and am building a testing update.  Once the update is ready, the updates system should automatically post in this bug telling you that the update is available.

Once it's available, please test it out and see if it solves the file parsing bug you are seeing.

Thanks.
Comment 4 Fedora Update System 2009-08-05 00:23:23 EDT
dhcp-4.1.0-24.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dhcp-4.1.0-24.fc11
Comment 5 Fedora Update System 2009-08-07 00:57:58 EDT
dhcp-4.1.0-24.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8325
Comment 6 Christopher Beland 2009-08-08 13:01:05 EDT
I'm still seeing the same warnings with dhclient-4.1.0p1-1.fc11.i586 after an update and two reboots.  Oddly, the filename is still dhclient-8a78b26a-e12c-49e1-8c83-b2b70d7512aa-wlan0.lease, but the timestamp on that file is after the second reboot.
Comment 7 Fedora Update System 2009-08-26 16:28:11 EDT
dhcp-4.1.0p1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dhcp-4.1.0p1-3.fc11
Comment 8 Fedora Update System 2009-08-27 18:55:01 EDT
dhcp-4.1.0p1-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9075
Comment 9 Jiri Popelka 2009-10-26 04:18:38 EDT
*** Bug 530821 has been marked as a duplicate of this bug. ***
Comment 10 Mads Kiilerich 2009-10-26 06:45:14 EDT
Summarizing the duplicate bug 530821: 
I (still) see the issue with dhclient-4.1.0p1-12.fc12.i686
Comment 11 Mads Kiilerich 2009-11-16 05:46:27 EST
I just noticed that NetworkManager apparently also has some deep integration with dhclient. Perhaps that plays a role here. Just an idea ...
Comment 12 Christopher Beland 2010-01-17 14:03:26 EST
Seeing the same errors with dhclient-4.1.0p1-16.fc12.i686.
Comment 13 Jiri Popelka 2010-05-11 03:23:58 EDT
*** Bug 531222 has been marked as a duplicate of this bug. ***
Comment 14 sergeobelare 2010-05-14 07:22:19 EDT
I have the same problem. Is there any information, logs, etc., that I can provide to assist? I also have ongoing continuous associate / dissociate wireless issues and wonder if they are somehow related to the lease file parsing error and NetworkManager.

Installed Packages
Name       : dhclient
Arch       : i686
Epoch      : 12
Version    : 4.1.1
Release    : 13.fc12
Comment 15 Jiri Popelka 2010-05-14 07:33:35 EDT
(In reply to comment #14)
> I have the same problem. Is there any information, logs, etc., that I can
> provide to assist?
I saw the log end lease file in bug #531222, so there's probably nothing more you can provide to assist now.  Thanks
Comment 16 Jiri Popelka 2010-06-29 08:38:59 EDT
Problem was not in writing out lease files in the right format as David supposed in comment #3, but in parsing of the date in lease file.

In detail:
Since 4.0.0 common/parse.c::parse_date()
has been renamed to parse_date_core()
and new parse_date() function has been created
as a wrapper around parse_date_core()
to consume the semicolon after the date.

However parse_date_core() has not been properly
updated and still tries to consume semicolon on it's own
with parse_semi() or skip_to_semi().
Comment 17 Fedora Update System 2010-06-29 08:40:05 EDT
dhcp-4.1.1-18.P1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dhcp-4.1.1-18.P1.fc12
Comment 18 Fedora Update System 2010-06-29 08:40:27 EDT
dhcp-4.1.1-23.P1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/dhcp-4.1.1-23.P1.fc13
Comment 19 Fedora Update System 2010-06-30 11:10:31 EDT
dhcp-4.1.1-18.P1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dhcp-4.1.1-18.P1.fc12
Comment 20 Fedora Update System 2010-06-30 11:16:47 EDT
dhcp-4.1.1-23.P1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dhcp-4.1.1-23.P1.fc13
Comment 21 Fedora Update System 2010-07-08 14:21:17 EDT
dhcp-4.1.1-23.P1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2010-08-10 17:38:36 EDT
dhcp-4.1.1-18.P1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 udo 2010-09-13 09:59:30 EDT
I get:

# dhclient -6 -d -P  ppp0
Internet Systems Consortium DHCP Client 4.2.0
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

/var/lib/dhclient/dhclient6.leases line 17: semicolon expected.
  option 
   ^
/var/lib/dhclient/dhclient6.leases line 35: semicolon expected.
  option 
   ^
/var/lib/dhclient/dhclient6.leases line 53: semicolon expected.
  option 
   ^
/var/lib/dhclient/dhclient6.leases line 71: semicolon expected.
  option 
   ^
/var/lib/dhclient/dhclient6.leases line 89: semicolon expected.
  option 
   ^
/var/lib/dhclient/dhclient6.leases line 107: semicolon expected.
  option 
   ^
/var/lib/dhclient/dhclient6.leases line 125: semicolon expected.
  option 
   ^
/var/lib/dhclient/dhclient6.leases line 143: semicolon expected.
  option 
   ^
/var/lib/dhclient/dhclient6.leases line 161: semicolon expected.
  option 
   ^
Bound to *:546

Yes, 4.2.0. Same bug?
I was referred to this bugzilla entry because dhcp on RHEL is treated differently. (!?)
Comment 24 Jiri Popelka 2010-09-13 11:02:43 EDT
Seems like different issue. Filled a bug #633318.