Bug 515121

Summary: alsa-plugins-pulseaudio causes Adobe Flash 10 to hang after playing for a time
Product: [Fedora] Fedora Reporter: David Batson <dkbatson>
Component: alsa-pluginsAssignee: Lennart Poettering <lpoetter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: eric.moret, florian.fahr
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-24 10:37:36 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
Pulseaudio debug messages
Error log when playing stuff in Rhythmbox none

Description David Batson 2009-08-02 07:55:23 EDT
Description of problem:
When watching a youtube video, after a period of time from 1-5 minutes the video stops playing.  The video might start again after some seconds, but without sound.  Problem occurs in both Opera 10 beta 2 and Firefox 3.5.1.  Problem occurs with Adobe Flash and Adobe Flash  Libflashsupport is NOT installed.  This is on a recent install of Fedora 11 from the 32-bit DVD.

Note when video stops, pulseaudio suddenly begins using >70% CPU, then after some seconds it crashes.

Version-Release number of selected component (if applicable):
alsa-plugins-pulseaudio 10.0.20-2.fc11

How reproducible:
Play a youtube flash video that lasts for several minutes.

Steps to Reproduce:
1.Play youtube video to completion: http://www.youtube.com/watch?v=K-DdstKANYg
Actual results:
Video hangs and sound is lost after playing for over 1 minute.  Video may resume, but without sound.

Expected results:
Video to play with sound to completion without hanging.

Additional info:
Uninstalling alsa-plugins-pulseaudio solves the problem.  Unsure of the side consequences of this.

Related forum thread: http://forums.fedoraforum.org/showthread.php?t=227344

I am using Fedora 11 on a T42 ThinkPad with an Analog Devices AC'97 Audio controller.

Here is a crash file that happened one time: operapluginwrapper-bugreport.txt
Comment 1 David Batson 2009-08-11 13:15:37 EDT
It appears that the problem was more than just alsa-plugins-pulseaudio.  While removing alsa-plugins-pulseaudio seemed to fix the problems I was having in youtube (Adobe Flash), the same problem later appeared when playing a test wmv video file - OldRepublic.wmv

I found OldRepublic.wmv in a link of the following guide and played it.  It played for a time, then the sound quit while the video continued.  I decided to perform the steps in the guide, and this allowed OldRepublic.wmv to play properly to completion as well as the youtube video I linked in the opening post.  Note that when following this guide, alsa-plugins-pulseaudio was reinstalled.  Both OldRepublic.wmv and the youtube video linked above played fine with alsa-plugins-pulseaudio after following the guide.

Fedora 11: Complete guide to fix PulseAudio and video/audio VLC Media Player issues

My guess is that the default setup of pulseaudio should be changed in F11.  Exactly what should be done is beyond my expertise.
Comment 2 Lennart Poettering 2009-08-17 15:27:49 EDT
Sorry, Flash is closed source software. We cannot debug this.

Please grep syslog for any PulseAudio related messages and paste them here.
Comment 3 Florian Fahr 2009-08-23 05:23:49 EDT
Created attachment 358345 [details]
Pulseaudio debug messages

This is what Pulseaudio outputs every time I play some Flash video. Note that about four or five weeks ago (when I was last using my Fedora box) it was still working perfectly.
Comment 4 Florian Fahr 2009-08-23 07:13:49 EDT
Created attachment 358346 [details]
Error log when playing stuff in Rhythmbox

Whoops... You too, Rhythmbox?
Comment 5 Lennart Poettering 2009-08-24 10:37:36 EDT
I am really not sure how I could makes this any more explicit in the logs. You snd_pcm_avail is overflowing.

*** This bug has been marked as a duplicate of bug 506075 ***
Comment 6 Florian Fahr 2009-08-25 12:18:07 EDT
Didn't see that bug... could have looked for it, tho.