Bug 515151

Summary: snd-intel8x0 driver has PCM problem that causes sound to cut out
Product: [Fedora] Fedora Reporter: Matt Foster <wedgef5>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: itamar, kernel-maint, lkundrak
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-03 04:30:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Matt Foster 2009-08-02 15:18:05 EDT
Description of problem: Sound cuts out shortly after beginning to play sound.  It seems to occur most often when viewing Flash content in Firefox.  ALSA bug tracker (https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4568) indicates a problem the the PCM pointer callback.  The above bug tracker entry refers to a patch, but to the 2.6.30 and .31 kernels.


Version-Release number of selected component (if applicable):
2.6.29.6-213

How reproducible:
Frequently

Steps to Reproduce:
1. Load Flash content in FF.  YouTube videos can cause it.
2. Stop and start a few times
3. Audio is lost
  
Actual results:
Sound stops completely or there is only a popping sound coming from the speakers

Expected results:
Clear sound throughout the content

Additional info:
Output in /var/log/messages from ALSA/pulseaudio:

Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-sink.c: Increasing minimal latency to 36.00 ms                                                                     
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294961108 bytes (24347852 ms).              
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.                                                                              
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c: snd_pcm_dump():            
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0                                                      
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c: Its setup is:              
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   stream       : PLAYBACK  
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   access       : MMAP_INTERLEAVED                                                                          
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   format       : S16_LE    
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   subformat    : STD       
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   channels     : 2         
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   rate         : 44100     
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   exact rate   : 44100 (44100/1)                                                                           
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   msbits       : 16        
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   buffer_size  : 16384     
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   period_size  : 16384     
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   period_time  : 371519    
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   tstamp_mode  : ENABLE    
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   period_step  : 1         
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   avail_min    : 16384     
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   period_event : 0         
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   start_threshold  : -1    
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   stop_threshold   : 1073741824                                                                            
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   silence_threshold: 0     
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   silence_size : 0         
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   boundary     : 1073741824
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   appl_ptr     : 12092940  
Aug  2 14:09:01 anvil pulseaudio[5013]: alsa-util.c:   hw_ptr       : 12075009
Comment 1 Lubomir Rintel 2009-08-03 04:30:25 EDT

*** This bug has been marked as a duplicate of bug 506075 ***