Bug 516117

Summary: Add publican module to Fedora's Transifex instance at translate.fedoraproject.org
Product: [Community] Publican Reporter: Karsten Wade <kwade>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 1.6CC: jfearn, mmcallis, mospina, piotrdrag, publican-list, r.landmann, rlandman
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://translate.fedoraproject.org
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-13 06:53:47 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 527327    
Bug Blocks:    

Description Karsten Wade 2009-08-06 15:43:49 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Karsten Wade 2009-08-06 15:47:10 EDT
Sorry about the double-tap, here's the real request.

Can we coordinate with Fedora L10n to get publican added as a module in Fedora's Transifex instance?

https://translate.fedoraproject.org

In addition to general l10n for Publican, we may want to translate parts of the content in brand-specific modules.

Should I file a separate bug for publican-fedora to be added, or can this one bug cover it all?
Comment 2 Jeff Fearn 2009-08-10 20:51:38 EDT
One bug is fine, we will probably use components for the brands and such.

I will get on to this when I get back from holidays, after the 24th August.
Comment 3 Jeff Fearn 2009-09-30 00:57:55 EDT
It turns out that the current install of transifex at https://translate.fedoraproject.org/ is too old to support multiple files per language, so this ticket will have to wait until after that site is updated.

The site is version 0.5.2 and multi-file support was added in version 0.6

It also occurs to me that transifex is setup to support the POSIX locales used by gettext (ISO 639 and ISO 3166 joined with an underscore), but publican, being and XML processing tool, uses RFC 4646 for language identification. This is probably going to cause problems.

Cheers, Jeff.
Comment 4 Ruediger Landmann 2009-09-30 01:06:15 EDT
(In reply to comment #3)

> It also occurs to me that transifex is setup to support the POSIX locales used
> by gettext (ISO 639 and ISO 3166 joined with an underscore), but publican,
> being and XML processing tool, uses RFC 4646 for language identification. This
> is probably going to cause problems.

This was fixed in more recent versions of Transifex (0.7?) -- it now supports the BCP 47/RFC 4646 codes too: http://transifex.org/changeset/780
Comment 5 Jeff Fearn 2009-09-30 16:56:25 EDT
(In reply to comment #4)
> (In reply to comment #3)
> 
> > It also occurs to me that transifex is setup to support the POSIX locales used
> > by gettext (ISO 639 and ISO 3166 joined with an underscore), but publican,
> > being and XML processing tool, uses RFC 4646 for language identification. This
> > is probably going to cause problems.
> 
> This was fixed in more recent versions of Transifex (0.7?) -- it now supports
> the BCP 47/RFC 4646 codes too: http://transifex.org/changeset/780  

Ah, very cool!

Looks like it was 0.7 http://docs.transifex.org/releases/0.7.html
Comment 6 Piotr Drąg 2010-03-12 10:59:18 EST
I've added Common Content for Publican and publican-fedora. Now we should enable translation submission. Could you add transif user to appropriate FAS group?

https://translate.fedoraproject.org/projects/p/publican/
Comment 7 Ruediger Landmann 2010-03-12 20:56:16 EST
(In reply to comment #6)
> I've added Common Content for Publican and publican-fedora. Now we should
> enable translation submission. Could you add transif user to appropriate FAS
> group?

Thanks Piotr -- User transif is already part of group svnpublicn
Comment 8 Piotr Drąg 2010-03-13 06:53:47 EST
Submission to Common_Content and fedora-brand has been enabled. Thanks!