Bug 516931

Summary: konqueror crashes when changing font size or font face
Product: [Fedora] Fedora Reporter: William H. Haller <bill>
Component: kdebaseAssignee: Ngo Than <than>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: jreznik, kevin, lorenzo, ltinkl, mathstuf, rdieter, smparrish, than
Target Milestone: ---Keywords: MoveUpstream, Reopened, Triaged
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-29 12:35:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
Crash dump
exported adblock filters none

Description William H. Haller 2009-08-11 18:26:38 EDT
Created attachment 357091 [details]
Crash dump

Description of problem: When apply is clicked, konqueror segfaults. A restart brings you back to a running state again and the change is applied in the dialog box the next time you look.

Version-Release number of selected component (if applicable): konqueror version 4.3.00 (updates-testing)

How reproducible: always

Steps to Reproduce:
1. Settings->Configure Konqueror->Appearance->Fonts
2. Change the font face or font size
3. Click Apply
Actual results: Segmentation Fault

Expected results: No crash and pages refreshed to selected font face or font sized to selected font size.

Additional info: Multiple tabs are open and some are split windows. See attached crash dump.
Comment 1 Jaroslav Reznik 2009-08-12 04:53:24 EDT
Do you have Ad block enabled? If yes, could you try to disable it? There's suspicious KHTMLPart::runAdFilter() call before crash.

I can't reproduce it here...
Comment 2 Rex Dieter 2009-08-12 09:28:13 EDT
Not reproducible by me either.

rpm -q kdelibs kdebase konq-plugins
Comment 3 William H. Haller 2009-08-12 10:37:18 EDT
Created attachment 357180 [details]
exported adblock filters

This is an exported filter set I was using.
Comment 4 William H. Haller 2009-08-12 10:39:41 EDT
Adblock is the culprit. On an empty Konqueror, I can change font sizes without problem. If I load a saved session and try the same it dumps. If I disable adblock it works. Reenabling adblock dumps it again.

There was no change to the filter set from KDE 4.2 (it was a simple upgrade).
Comment 5 Steven M. Parrish 2009-09-12 21:19:51 EDT
Thanks for the update.  Going to close this as NOTABUG

Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
Comment 6 Kevin Kofler 2009-09-12 21:24:37 EDT
Huh? This is a bug, just in the AdBlock plugin and not in Konqueror itself.
Comment 7 Kevin Kofler 2009-09-12 21:25:25 EDT
Or rather, it's in the AdBlock functionality of Konqueror (it's builtin, not a plugin).
Comment 8 Steven M. Parrish 2009-09-29 11:27:27 EDT
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.

Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
Comment 9 William H. Haller 2009-09-29 12:21:16 EDT
http://bugs.kde.org/show_bug.cgi?id=208885 is the upstream bug number. FWIW, the situation is a bit more stable with 4.3.1, but the bug still occurs occasionally. With 4.3.00, it was almost always reproducible.
Comment 10 Rex Dieter 2009-09-29 12:35:15 EDT
thanks!  will continue to track the issue upstream.