Bug 517109

Summary: Closing one window causes another to close
Product: [Fedora] Fedora Reporter: Tim Waugh <twaugh>
Component: gnome-terminalAssignee: Behdad Esfahbod <behdad>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: behdad, mclasen, yaneti
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-02 09:41:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tim Waugh 2009-08-12 12:08:20 EDT
Description of problem:
Sometimes, pressing Ctrl-D to close one gnome-terminal window closes not just that window but another terminal window I had open.

Version-Release number of selected component (if applicable):
gnome-terminal-2.26.2-3.fc12.x86_64

How reproducible:
Three times today.
Comment 1 Yanko Kaneti 2009-08-25 08:12:17 EDT
It seems I can reproduce this. I have the gnome-terminal command line bellow bound to a metacity global keybinding. To reproduce just start two terminal windows with the keybinding and press Ctrl-D in the second one. The core has:

Core was generated by `gnome-terminal --geometry=90x40'.
Program terminated with signal 4, Illegal instruction.
#0  _dl_x86_64_restore_sse () at ../sysdeps/x86_64/dl-trampoline.S:223
223		vmovdqa %fs:RTLD_SAVESPACE_SSE+0*YMM_SIZE, %ymm0
(gdb) bt full
#0  _dl_x86_64_restore_sse () at ../sysdeps/x86_64/dl-trampoline.S:223
No locals.
#1  0x00007faf319896e5 in _dl_fixup (l=<value optimized out>, 
    reloc_arg=<value optimized out>) at ../elf/dl-runtime.c:126
        version = <value optimized out>
        flags = <value optimized out>
        reloc = <value optimized out>
        sym = 0x7faf2e5142d0
        result = 0x7faf31b68000
        value = <value optimized out>
        __PRETTY_FUNCTION__ = "_dl_fixup"
#2  0x00007faf3198fbb5 in _dl_runtime_resolve () at ../sysdeps/x86_64/dl-trampoline.S:41
No locals.
#3  0x00007faf31710da6 in vte_terminal_eof (channel=<value optimized out>, 
    terminal=0xbea800) at vte.c:3549
        object = <value optimized out>
#4  0x00007faf31710eec in vte_terminal_io_read (channel=<value optimized out>, 
    condition=<value optimized out>, terminal=0xbea800) at vte.c:4205
        err = 32687
        eof = 16
        again = 0
#5  0x00007faf2e54919e in g_main_dispatch (context=<value optimized out>) at gmain.c:1960
        dispatch = 0x7faf2e57e400 <g_io_unix_dispatch>
        user_data = can't compute CFA for this frame
Comment 2 Tim Waugh 2009-08-26 09:43:07 EDT
Still seeing this problem with:

gnome-terminal-2.27.91-1.fc12.x86_64
vte-0.21.4-1.fc12.x86_64
Comment 3 Behdad Esfahbod 2009-08-26 14:08:56 EDT
Can't reproduce.  Another 64bit bug?  A bit of debugging help is needed.
Comment 4 Yanko Kaneti 2009-08-26 15:22:45 EDT
The trace reads like this bug 519081 .
glibc fix pending a successfull koji build. I'll try it again then.
Comment 5 Behdad Esfahbod 2009-08-26 15:26:00 EDT
Oh, interesting.
Comment 6 Yanko Kaneti 2009-08-29 12:26:21 EDT
I can't reproduce this any more with glibc-2.10.90-17.x86_64. Not that it was 100% reproducible before but it as at least 1/5 times. Sorry for hijacking this bug, as Tim hasn't confirmed that what he is seeing are actually crashes or something else. If it were crashes then there should be traces in the syslog...
gnome-terminal[5452] trap invalid opcode ip:7f56b26a4229 sp:7fffa4f335b8 error:0 in ld-2.10.90.so[7f56b268f000+20000]
or somesuch.
Comment 7 Matthias Clasen 2009-08-29 12:56:36 EDT
Tim, can you confirm that this is fixed ?
Comment 8 Tim Waugh 2009-09-02 04:30:02 EDT
Hasn't happened since, so I think this is fixed, yes.