Bug 517339

Summary: initscript does not proper catch not existing pid files
Product: [Fedora] Fedora EPEL Reporter: Peter Bieringer <pb>
Component: syslog-ngAssignee: Ray Van Dolson <rayvd>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: el5CC: jose.p.oliveira.oss, rayvd, silfreed
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-15 21:30:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 518582    
Bug Blocks:    

Description Peter Bieringer 2009-08-13 14:54:42 UTC
Description of problem:
uncatched error if pid file does not exist on stop

Version-Release number of selected component (if applicable):
syslog-ng-2.1.4-1.el5

How reproducible:
Always

Steps to Reproduce:

# /etc/init.d/syslog-ng stop
Stopping syslog-ng:                                        [  OK  ]

# /etc/init.d/syslog-ng restart
Stopping syslog-ng: /etc/init.d/syslog-ng: line 70: /var/run/syslog-ng.pid: No such file or directory
/etc/init.d/syslog-ng: line 70: /var/run/syslogd.pid: No such file or directory
                                                           [FAILED]
Starting syslog-ng:                                        [  OK  ]


Actual results:
see above


Expected results:
Not such strange error message


Additional info:

Comment 1 Ray Van Dolson 2009-08-19 07:08:47 UTC
Commited this patch[1] to devel/ which I believe will solve the issue.  However, I was unable to build the package for EL-5 due to some linking errors against libnet.  Will have to resolve this first.

[1] http://cvs.fedora.redhat.com/viewvc/rpms/syslog-ng/devel/syslog-ng.init.d?r1=1.1&r2=1.2

Comment 2 Jose Pedro Oliveira 2012-01-15 21:30:25 UTC
Closing this ticket as the problem appears to have been fixed in syslog-ng-2.1.4-3.  Please feel free to re-open this ticket if the problem still persist.

Specfile changelog:
...
* Tue Aug 18 2009 Ray Van Dolson <rayvd@fedoraproject.org> - 2.1.4-3
- Init script fix (bug#517339)
...


/jpo