Bug 517876

Summary: spacewalk-koan requires up2date on Fedora 11
Product: [Community] Spacewalk Reporter: Sandro Mathys <sandro>
Component: ClientsAssignee: Justin Sherrill <jsherril>
Status: CLOSED CURRENTRELEASE QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: low    
Version: 0.6CC: jsherril
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-12-07 12:02:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 507670    

Description Sandro Mathys 2009-08-17 16:03:12 UTC
Description of problem:
When one tries to install spacewalk-koan on F11, he'll get an error that up2date is missing:
Error: Missing Dependency: up2date is needed by package spacewalk-koan-0.1.17-1.fc11.noarch (spacewalk-koan-0.1.17-1.fc11.noarch.rpm)

Correctly, up2date should only be necessary on RHEL 3/4, i.e. the Requires of the spacewalk-koan rpm should be fixed.



Version-Release number of selected component (if applicable):
spacewalk-koan-0.1.17-1.fc11.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Get a F11 box
2. Add the spacewalk repo
3. yum install spacewalk-koan
  
Actual results:
spacewalk-koan won't install because of missing up2date

Expected results:
spacewalk-koan installs on F11 without up2date

Additional info:
From #spacewalk:
[17:51:12] <mccun934> # If this is rhel 4 or less we need up2date.
[17:51:12] <mccun934> %if 0%{?rhel} < 5
[17:51:12] <mccun934> Requires: up2date
[17:51:21] <mccun934> jsherrill: that must not be working on f11
[17:51:23] <jsherrill> mccun934, we had to change the requires logic to get it to work with 2.1 correctly and i'm guessing it's not working with f11
[17:51:28] <jsherrill> yeah
[17:51:35] *  mccun934 curses 2.1
[17:51:40] <jsherrill> yeah :/
[17:51:48] <jsherrill> we could probably just change it now back and rebuild it
[17:51:55] <jsherrill> worry about 2.1 again when we need to
[17:52:31] <red_alert> rpm --eval "%if 0%{?rhel} < 5"
[17:52:31] <red_alert> %if 0 < 5
[17:52:44] <red_alert> on f11
[17:54:14] <mccun934> jsherrill: agreed

Comment 1 Justin Sherrill 2009-08-17 16:33:48 UTC
fixed:  9a98cf9

Comment 2 Miroslav Suchý 2009-12-07 12:02:48 UTC
Spacewalk 0.7 released.