Bug 518359

Summary: pulseaudio device or resource busy error
Product: [Fedora] Fedora Reporter: Randy Yates <yates>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: lkundrak, lpoetter, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-22 01:39:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
the audio file used by gnome-mplayer to play a radio station
none
alsa-info file, newly generated none

Description Randy Yates 2009-08-20 03:46:42 UTC
Description of problem:

When gnome-mplayer is running playing a radio station, mail-notification
will not play the notification sound (I'm using the "Display Test Messages"
utility in the mail-notification properties dialog). However, when gnome-mplayer
is not running, I get the mail-notification sound.

The mail-notification sound event is generating one or two errors in the messages log:

Aug 19 23:25:19 localhost pulseaudio[2407]: alsa-sink.c: Error opening PCM device front:0: Device or resource busy
Aug 19 23:25:19 localhost pulseaudio[2407]: sink-input.c: Failed to create sink input: sink is suspended.

Version-Release number of selected component (if applicable):

Installed Packages
Name       : pulseaudio
Arch       : x86_64
Version    : 0.9.15
Release    : 14.fc11
Size       : 1.9 M
Repo       : installed
From repo  : updates
Summary    : Improved Linux sound server
URL        : http://pulseaudio.org
License    : GPLv2+
Description: PulseAudio is a sound server for Linux and other Unix like operating
           : systems. It is intended to be an improved drop-in replacement for the
           : Enlightened Sound Daemon (ESOUND).

Installed Packages
Name       : mail-notification
Arch       : x86_64
Version    : 5.4
Release    : 10.fc11
Size       : 1.2 M
Repo       : installed
From repo  : fedora
Summary    : Status icon that informs you if you have new mail
URL        : http://www.nongnu.org/mailnotify/
License    : GPLv3+
Description: Mail Notification is a status icon (aka tray icon) that informs you if you
           : have new mail. It works with system trays implementing the freedesktop.org
           : System Tray Specification, such as the GNOME Panel Notification Area, the
           : Xfce Notification Area and the KDE System Tray.

How reproducible:

Not sure. It's doing it now, in this gnome login session, every time. 

Steps to Reproduce:
1. Run gnome-mplayer and play a radio station:
  gnome-mplayer /home/media/radio/wcpe.m3u
2. System/Preferences/Mail Notification
3. Ensure the "play a sound when new mail arrives" is checked and a valie
   sound file is selected.
4. Press the "Display test messages" checkbox
  
Actual results:

No mail notification sound occurs.

Expected results:

A mail notification sound is emitted.

Other info:
Linux localhost.localdomain 2.6.29.6-217.2.8.fc11.x86_64 #1 SMP Sat Aug 15 01:06:26 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Comment 1 Randy Yates 2009-08-20 03:48:32 UTC
Created attachment 358030 [details]
the audio file used by gnome-mplayer to play a radio station

Comment 2 Randy Yates 2009-08-20 03:51:33 UTC
Created attachment 358031 [details]
alsa-info file, newly generated

Comment 3 Lennart Poettering 2009-08-21 17:08:38 UTC
If you get 'busy' back from the device then some other application seems to block access to PA. fuser -v /dev/snd/* might tell you which one.

Comment 4 Randy Yates 2009-08-22 01:29:58 UTC
He Lennart,

When gnome-mplayer is running, I get this:

[root@localhost ~]# fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  yates      6174 F.... pulseaudio
                     yates      9460 f.... mplayer
/dev/snd/pcmC0D0p:   yates      9460 F...m mplayer
/dev/snd/timer:      yates      9460 f.... mplayer

When it isn't running, I get this:

[root@localhost ~]# fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  yates      6174 F.... pulseaudio


But this isn't any surprise, is it?

Comment 5 Randy Yates 2009-08-22 01:39:59 UTC
Doh! Man am I stupid. I had gnome-mplayer's output driver set for alsa and not pulse. Sorry!