Bug 518582

Summary: syslog-ng needs to link dynamically against libnet
Product: [Fedora] Fedora EPEL Reporter: Ray Van Dolson <rayvd>
Component: syslog-ngAssignee: Ray Van Dolson <rayvd>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: el5CC: rayvd, redhat-bugzilla, silfreed, tremble
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: syslog-ng-2.1.4-9.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-02 19:14:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 518150    
Bug Blocks: 517339    

Description Ray Van Dolson 2009-08-21 03:52:34 UTC
New versions of libnet no longer provide a .a to statically link against.  Need to dynamically link against libnet after it is moved to /lib.

Comment 1 Ray Van Dolson 2009-08-21 03:57:07 UTC
http://rayvd.fedorapeople.org/syslog-ng/syslog-ng.spec
http://rayvd.fedorapeople.org/syslog-ng/syslog-ng-2.1.4-4.src.rpm
http://rayvd.fedorapeople.org/syslog-ng/syslog-ng-2.1.4-libnet.patch

I believe these resolve the issue for EL5.  Need to test for EL4 as well.  I
don't believe this patch needs to be applied for Fedora as it already does
dynamic linking and should follow the library when it moves to /lib.

Added a BuildRequires for automake due to modified configure.in.

Comment 2 Ray Van Dolson 2009-08-21 21:24:03 UTC
Initial test build locally against the new version of libnet works fine on EL5.  Will test via koji once the libnet update is pushed to -testing.

Comment 3 Mark Chappell 2010-09-22 10:22:38 UTC
Ray, 

We're trying to have a bit of a clear out of the EPEL bug queue

Looks like you built the package but never pushed an update, did it work? is there any reason you didn't push the update that the rest of us could help with?

Comment 4 Ray Van Dolson 2010-10-18 04:08:38 UTC
Totally need to revisit this one and see where syslog-ng stands in EPEL.  Yes, this was resolved, but we may need to move on to a newer version of syslog-ng at this point.

Going to try and give this some TLC over the next two weeks.

Comment 5 Fedora Update System 2011-05-16 14:25:56 UTC
syslog-ng-2.1.4-9.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/syslog-ng-2.1.4-9.el5

Comment 6 Fedora Update System 2011-05-16 21:04:12 UTC
Package syslog-ng-2.1.4-9.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing syslog-ng-2.1.4-9.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/syslog-ng-2.1.4-9.el5
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-06-02 19:13:55 UTC
syslog-ng-2.1.4-9.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.