Bug 518726

Summary: F11 udev fails for usb-serial (ftdi_sio driver)
Product: [Fedora] Fedora Reporter: Jim <jhettmer>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 11CC: harald
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-03-19 05:54:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
shows udev .rules file and results for FC6 (correct) and F11 (wrong) none

Description Jim 2009-08-21 17:05:01 EDT
Created attachment 358281 [details]
shows udev .rules file and results for FC6 (correct) and F11 (wrong)

Description of problem:
In udev rules, matching KERNEL=="ttyUSB*" yields null for the %s{serial} substitution.  Only when %k is "2-6" (for example) is %s{serial} found in the device tree.  In FC6 the same udev .rules file and the same USB-serial device are correctly identified by the device srial number.  This makes F11 unuseable where different USB-serial devices need to be differentiated.

Version-Release number of selected component (if applicable):
Kernels fc11.191 and fc11.213, udev versions 141-4 and 141-3.


How reproducible:
Always, and with two different mfr's of usb-serial (ftdi) devices.

Steps to Reproduce:
1.Plug in USB-serial device with unique serial number with a suitalble udev debugging rule
2.Observe that the device serial number was not usefully available.
3.
  
Actual results:
Device attributes (including serial number) not available when KERNEL== matches the device

Expected results:
Device attributes available as per udev instructions.

Additional info:  Attached are the debug .rules file and the result on an FC6 and an F11 system.
Comment 1 Harald Hoyer 2009-08-24 02:58:13 EDT
I see no difference in the attached output, nevertheless, I'll have a look.
Comment 2 Jim 2009-08-25 15:34:08 EDT
My hasty error rushing to an appointment.  The F11 output is as follows.  The serial number is seen only on the first line, on all others it is null.  Sorry.:

09/08/21 16:10             0  644    root NOTUSB-k2-6-s00002164
09/08/21 16:10             0  644    root NOTUSB-k2-6:1.0-s
09/08/21 16:10             0  644    root NOTUSB-kusbdev2.13_ep00-s
09/08/21 16:10             0  644    root NOTUSB-kusbdev2.13_ep02-s
09/08/21 16:10             0  644    root NOTUSB-kusbdev2.13_ep81-s
09/08/21 16:10             0  644    root NOTUSB-kusbdev2.4_ep06-s
09/08/21 16:10             0  644    root USB-ttyUSB0-
09/08/21 16:10             0  644    root add--k2-6:1.0
09/08/21 16:10             0  644    root add--kttyUSB0
09/08/21 16:10             0  644    root add--kusbdev2.13_ep00
09/08/21 16:10             0  644    root add--kusbdev2.13_ep02
09/08/21 16:10             0  644    root add--kusbdev2.13_ep81
09/08/21 16:10             0  644    root add--kusbdev2.4_ep06
09/08/21 16:10             0  644    root add-00002164-k2-6
Comment 3 Harald Hoyer 2010-03-17 07:52:50 EDT
hmm, are these different kernels? Does the sysfs file exist at that point of time?
Comment 4 Jim 2010-03-18 18:58:15 EDT
Unfortunately, due to conditions beyond my control, I no longer have, nor can I resurrect, an F11 system with which to provide further information.  The F11 kernel would have been whatever was "current" on  2009-08-25 (64-bit).  The FC6 kernel I compared it with was almost certainly 2.6.20-1.2962.fc6 or something very close to that.  As far as I could tell at the time, this error seemed specific to USB-serial devices.  I will say that if any of the usual files and filesystems such as sysfs were not present I would have noticed it.  Again, the problem is that if we have several such ports it is very difficult to associate a particular USB-serial device with whatever it is attached to.  Quite possibly newer kernels and udevs handle this situation correctly;  unfortunately, the economy has changed our universe here and I can't be of any help.  Thank you for your interest, though.
Comment 5 Harald Hoyer 2010-03-19 05:54:15 EDT
Anyway, I think this is not udev's fault. Something in the kernel driver / sysfs layout may have changed, so that "serial" either does not exist or is empty at that point of time.