Bug 518970

Summary: ibus-daemon persists after desktop session
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: imsettingsAssignee: Akira TAGOH <tagoh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: i18n-bugs, phuang, tagoh
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-08 08:28:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
.imsettings.log none

Description Jens Petersen 2009-08-24 08:32:41 EDT
Created attachment 358445 [details]
.imsettings.log

Description of problem:
With the latest ibus and imsettings in rawhide
a bubble is appearing for me at startup that ibus
startup failed because of spawning too many ibus processes.

Version-Release number of selected component (if applicable):
imsettings-0.107.1-2.fc12
ibus-1.2.0.20090812-1.fc12

How reproducible:
every time

Steps to Reproduce:
1. login to desktop
  
Actual results:
warning bubble appears

Expected results:
ibus to be running normally
Comment 1 Jens Petersen 2009-08-24 08:50:54 EDT
Meant to add after (re)booting ibus works on first login and then stops
on further desktop sessions.

After I logout I see an "ibus-daemon --xim" process.
Comment 2 Akira TAGOH 2009-08-25 00:52:13 EDT
probably imsettings fault.  Though the process of "ibus-daemon --xim" should has deps of X, I'm not sure why it still keeps running even after X is killed.
Comment 3 Akira TAGOH 2009-08-26 08:19:07 EDT
Confirmed. I can reproduce this issue and can see ibus-daemon running even after logging out the desktop.
Comment 4 Peng Huang 2009-08-26 23:00:52 EDT
Is process ibus-x11 alive after logout?
Comment 5 Akira TAGOH 2009-08-26 23:20:00 EDT
(In reply to comment #4)
> Is process ibus-x11 alive after logout?  

Yes, and it just restarted because ibus process has been gone with the disconnect signal before imsettings is aware of it. FWIW I found the interesting log in .imsettings.log for the first session:

IM-Settings-Daemon[2646]: WARNING **: Main Input Method process for IBus died with the signal 11, but unexpectedly. restarting...

This means ibus-x11 process that still keeps running was surely brought up by imsettings again though, but it killed by SIGSEGV. there may be a bug in ibus on the handling of the disconnect signal or so.


Anyway, I got a fix for this issue, testing now.
Comment 6 Peng Huang 2009-08-27 00:41:57 EDT
IBus has a problem during finalizing. It has been fixed in upstream. I will build new ibus version soon.
Comment 7 Peng Huang 2009-08-27 01:19:06 EDT
https://koji.fedoraproject.org/koji/taskinfo?taskID=1637248
A scratch build, please test it.
Comment 8 Akira TAGOH 2009-08-27 04:12:29 EDT
Looks good. no segfault with the disconnect signal anymore but just exit with the status 0 now. thanks!

Anyway, the root cause of this issue should be fixed in imsettings-0.107.2-1.fc12.