Bug 51900

Summary: require e2fsprogs and readline versions
Product: [Retired] Red Hat Linux Reporter: Pekka Savola <pekkas>
Component: dumpAssignee: Mike A. Harris <mharris>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2Keywords: FutureFeature
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-11-05 13:49:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pekka Savola 2001-08-16 17:31:14 UTC
dump-0.4b22-4.src.rpm  or even dump-0.4b19-5.6x.src.rpm will not appear to rebuild on 
RHL62.  Errors include, but are not limited to:

/usr/bin/../lib/libext2fs.a(llseek.o): In function `ext2fs_llseek':
llseek.o(.text+0x55): the `llseek' function may be dangerous; use `lseek64' instead.
/usr/bin/../lib/libcom_err.a(com_err.o): In function `default_com_err_proc':
com_err.o(.text+0x17): undefined reference to `_IO_stderr_'
com_err.o(.text+0x22): undefined reference to `_IO_stderr_'
com_err.o(.text+0x38): undefined reference to `_IO_stderr_'
com_err.o(.text+0x4c): undefined reference to `_IO_stderr_'
com_err.o(.text+0x64): undefined reference to `_IO_stderr_'
/usr/bin/../lib/libcom_err.a(com_err.o)(.text+0x71): more undefined references to `_IO_stderr_' follow

Upgrading to rawhide e2fsprogs, e2fsprogs-devel, readline, readline-devel fixed this.

As rebuilding rawhide dump works on unmodified RHL7.0, I suggest adding required versions:

BuildPrereq: e2fsprogs-devel, libtermcap-devel, readline-devel

to:

BuildPrereq: e2fsprogs-devel >= 1.18, libtermcap-devel, readline-devel >= 4.1

Comment 1 Mike A. Harris 2001-11-06 14:07:02 UTC
Fixed in rawhide dump-0.4b22-7.src.rpm