Bug 519316

Summary: KDE display components disappeared after upgrade
Product: [Fedora] Fedora Reporter: Xi Yang <jiandingzhe>
Component: kdebaseAssignee: Ngo Than <than>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: jreznik, kevin, lorenzo, ltinkl, mathstuf, rdieter, smparrish, than
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-26 10:21:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
snapshot of screen none

Description Xi Yang 2009-08-26 05:00:59 UTC
After I upgrade the system at 2009-8-26, some KDE4 components disappeared, or working unproperly. These includes:

1: Desktop background picture:
    disappeared, changed to displaying black-white grid.
2: Widgets that were put on desktop:
    disappeared.
3: The "system tray" widget:
    all contents disappeared.
4: Plasma control button on right-top corner of screen:
    disappeared.
5: Start menu:
    After clicks the start button, it appears on left-top of screen, which originally on left-bottom.

I have tried to disable desktop effects, reinstall nvidia driver to rewrite the xconfig file, but those not work.

Comment 1 Xi Yang 2009-08-26 05:01:45 UTC
Created attachment 358668 [details]
snapshot of screen

Comment 2 Xi Yang 2009-08-26 05:05:06 UTC
My kdebase version: 6:4.2.4-2.fc11

Comment 3 Kevin Kofler 2009-08-26 08:28:07 UTC
You appear to be running a mix of KDE 4.2.4 and 4.3.0, make sure you completely upgrade to 4.3.0. (Run "yum update" from a terminal if your KDE is too broken for KPackageKit to work.)

To get rid of your already broken Plasma configuration:
kquitapp plasma-desktop
mv -f ~/.kde/share/config/plasma-desktop-appletsrc ~/.kde/share/config/plasma-desktop-appletsrc.backup
plasma-desktop
(This assumes your Plasma is from 4.3.0. If you have 4.2.4 stuff left, make sure you upgrade that first.)

Also note that we cannot support the proprietary nvidia driver as we are unable to fix any bugs in it, because we neither ship it nor have its source code.

Comment 4 Xi Yang 2009-08-26 09:03:06 UTC
Problems resolved. Thanks a lot!
(In reply to comment #3)
> You appear to be running a mix of KDE 4.2.4 and 4.3.0, make sure you completely
> upgrade to 4.3.0. (Run "yum update" from a terminal if your KDE is too broken
> for KPackageKit to work.)
> 
> To get rid of your already broken Plasma configuration:
> kquitapp plasma-desktop
> mv -f ~/.kde/share/config/plasma-desktop-appletsrc
> ~/.kde/share/config/plasma-desktop-appletsrc.backup
> plasma-desktop
> (This assumes your Plasma is from 4.3.0. If you have 4.2.4 stuff left, make
> sure you upgrade that first.)
> 
> Also note that we cannot support the proprietary nvidia driver as we are unable
> to fix any bugs in it, because we neither ship it nor have its source code.