Bug 519321

Summary: rpl problem with -w option
Product: [Fedora] Fedora Reporter: Gerard Torrent <gerard>
Component: rplAssignee: Tim Jackson <rpm>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 11CC: rpm
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-09 12:55:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gerard Torrent 2009-08-26 06:58:53 UTC
Description of problem: 
-----------------------
the rpl -w option (match only on word boundaries) seems that don't work properly.

Version-Release number of selected component (if applicable): 
-------------------------------------------------------------
rpl-1.5.5-2.fc11

How reproducible:
-----------------
allways

Steps to Reproduce: 
-------------------
#!/bin/bash
#creating data file
rm -f test1.txt;
SEQ1=$(seq 15000);
for i in $SEQ1
do
  echo $i" : grande" >> test1.txt;
done
#running replace (with -w option -> 0 replaces)
SEQ2=$(seq 1);
for i in $SEQ2
do
  rpl -w "rande" "grande" test1.txt;
done
#showing error (more than 1 replaces done)
grep gg test1.txt;

Actual results:
---------------
some replacements made(grande -> ggrande)

Expected results:
-----------------
no replacements made

Additional info:
----------------
> uname -a
> Linux imd1.imagina.local 2.6.29.6-217.2.8.fc11.x86_64 #1 SMP Sat Aug 15 01:06:26 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
> python
> Python 2.6 (r26:66714, Jun  8 2009, 16:07:29)
> [GCC 4.4.0 20090506 (Red Hat 4.4.0-4)] on linux2

Comment 1 Tim Jackson 2009-08-26 21:40:39 UTC
I can reproduce. Filed upstream at https://sourceforge.net/tracker/?func=detail&aid=2845190&group_id=189512&atid=929622

Comment 2 Tim Jackson 2009-08-28 11:51:12 UTC
*** Bug 520064 has been marked as a duplicate of this bug. ***