Bug 519342

Summary: F12-Alpha PV xen guest crashes on RHEL5
Product: [Fedora] Fedora Reporter: Alexander Todorov <atodorov>
Component: kernel-xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED DUPLICATE QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-26 08:02:59 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 473303    

Description Alexander Todorov 2009-08-26 05:19:48 EDT
Description of problem:
F12-Alpha PV xen guest always crashes when the host system is RHEL5.4. 

virt-manager spews this traceback:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 724, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 643, in _do_install
    raise RuntimeError, _("It appears that your installation has crashed.  You should be able to find more information in the logs")
RuntimeError: It appears that your installation has crashed.  You should be able to find more information in the logs
'

xend.log says:

[2009-08-26 12:01:56 xend.XendDomainInfo 3332] WARNING (XendDomainInfo:1175) Domain has crashed: name=t3 id=4.
[2009-08-26 12:01:56 xend.XendDomainInfo 3332] DEBUG (XendDomainInfo:2119) XendDomainInfo.destroy: domid=4
[2009-08-26 12:01:56 xend.XendDomainInfo 3332] ERROR (XendDomainInfo:2129) XendDomainInfo.destroy: xc.domain_destroy failed.
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 2125, in destroy
    xc.domain_pause(self.domid)
Error: (3, 'No such process')

The problem is described in this thread on fedora-xen list:
https://www.redhat.com/archives/fedora-xen/2009-August/msg00008.html

A traceback from the thread is:

# /usr/lib/xen/bin/xenctx -s System.map-2.6.31-0.162.rc6.git2.fc12.i686.PAE 10
cs:eip: e019:c0aa14d1 xen_start_kernel+0x9 
flags: 00000292 i s nz a
ss:esp: e021:c0a99fcc
eax: 00000000   ebx: 00000000   ecx: 00000000   edx: 00000000
esi: c1489000   edi: 00000000   ebp: c0a99ffc
 ds:     e021    es:     e021    fs:     e021    gs:     e021
Code (instr addr c0aa14d1)
00 00 74 05 e8 15 be 9a ff c9 c3 00 55 89 e5 57 56 53 83 ec 14 <65> a1 14 00
00 00 89 45 f0 31 c0 


Stack:
 00000000 c0aa14d1 0001e019 00010092 00000000 00000000 00000000 00000000
 00000000 00000000 c1489000 00000000 00000000

Call Trace:
  [<c0aa14d1>] xen_start_kernel+0x9  <--

  [<c0aa14d1>] xen_start_kernel+0x9 


Additional info:
I'll try to get more recent stack trace from my F12-Alpha guest and update the bug.
Comment 1 Alexander Todorov 2009-08-26 07:17:03 EDT
From the host system:

# xm dmesg
(XEN) Unhandled page fault in domain 6 on VCPU 0 (ec=0000)
(XEN) Pagetable walk from 00000014:
(XEN)  L3[0x000] = 0000000000000000 ffffffff
(XEN) domain_crash_sync called from entry.S (ff184b7e)
(XEN) Domain 6 (vcpu#0) crashed on cpu#0:
(XEN) ----[ Xen-3.1.2-164.el5  x86_32p  debug=n  Not tainted ]----
(XEN) CPU:    0
(XEN) EIP:    e019:[<c0aa2553>]
(XEN) EFLAGS: 00000296   CONTEXT: guest
(XEN) eax: 00000000   ebx: 00000000   ecx: 00000007   edx: 00000000
(XEN) esi: c0ade280   edi: c0a0a738   ebp: c0a99fd8   esp: c0a99fbc
(XEN) cr0: 8005003b   cr4: 000026f0   cr3: 5b814000   cr2: 00000014
(XEN) ds: e021   es: e021   fs: e021   gs: e021   ss: e021   cs: e019
(XEN) Guest stack trace from esp=c0a99fbc:
(XEN)    00000000 c0aa2553 0001e019 00010096 00000000 c0ade280 c0a0a8ac c0a99ffc
(XEN)    c0aa16ba 00000000 00000000 00000000 00000000 00000000 c3738000 00000000
(XEN)    00000000 c082e464 c082e46c c0404b19 c0aa1cc3 c0405358 c0405635 c0405965
(XEN)    c0405b94 c0405c38 c0405f0e c0405f8f c0406265 c0406389 c0aa2605 c0aa260d
(XEN)    c082e516 c082e63c c04082f8 c040830a c0408393 c0408588 c04085cd c0408694
(XEN)    c0408be7 c0408f3e c0408f83 c0408f95 c04095c2 c0409c0b c0409c32 c040a12e
(XEN)    c0aa2e8f c0aa2f37 c083a77f c083a85d c083aaab c040cf30 c083ae1a c083aeb9
(XEN)    c083aed9 c0aa3628 c0aa3630 c040dcc5 c040deee c0aa3e9a c0aa4dc4 c0aa4dcc
(XEN)    c040f787 c040f795 c040f81b c040f829 c0aa6e93 c0aa6ea6 c0410b1d c0410bba
(XEN)    c0410f15 c0410fce c0411020 c0411046 c0411196 c04115ac c04118fb c0411927
(XEN)    c0412b98 c0412fe3 c041327e c0413288 c0413a81 c0413a89 c0413a91 c0413bb7
(XEN)    c0413c3f c0413c4e c0413c5c c0413cc7 c082ee5b c082efe4 c082f045 c082f060
(XEN)    c082f70c c082f828 c082f8f4 c082fabb c0aa767b c0aa7683 c0aa7695 c0aa769d
(XEN)    c0aa76a5 c0aa76ad c0aa76bf c0aa76c7 c0aa76ed c0aa76f5 c0aa776a c0aa7772
(XEN)    c082fd5d c0830016 c08300b0 c0830642 c08306dd c0830728 c0830822 c0830827
(XEN)    c083092a c083096c c0830971 c0830976 c0830990 c0830a87 c0830b03 c0830bb5
(XEN)    c0830bc3 c0830be8 c0830bf2 c0830c0e c0830c7d c0830c87 c0830cea c0830cef
(XEN)    c0830cf4 c0830cf9 c0830cfe c0830d1d c0830d29 c0830d4a c0830d53 c0830d5c
(XEN)    c0830e5a c0830e5f c0830e7e c0830eae c0830f1e c0830f75 c0830f7a c0831189
(XEN)    c08311f4 c0831284 c0831290 c083135f c0831370 c0831469 c0831602 c083160d
Comment 2 Alexander Todorov 2009-08-26 08:02:59 EDT

*** This bug has been marked as a duplicate of bug 508120 ***