Bug 519787

Summary: qemu-kvm exits when initializing MSI-X fails on older kernels
Product: [Fedora] Fedora Reporter: Jan ONDREJ <ondrejj>
Component: qemuAssignee: Glauber Costa <gcosta>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: berrange, dwmw2, gcosta, gczarcinski, itamar, jaswinder, markmc, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: https://www.redhat.com/archives/fedora-virt/2009-August/msg00121.html
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-07 03:04:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 498968    

Description Jan ONDREJ 2009-08-27 15:19:05 EDT
Description of problem:
As also described in fedora-virt mailinglist by Gene Czarcinski, F12-Alpha fails to run under Fedora 11 + virt-preview. It boots, but then qemu process dies. Log from libvirt/qemu/ attached below. I use qcow2 image for virtual machine.

Version-Release number of selected component (if applicable):
fedora-release-11-1.noarch
qemu-0.10.91-0.5.rc1.fc11.i586
libvirt-0.7.0-6.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. trying to boot using PXE (without gPXE, which still does not boot on F11)
2. trying to boot F11-Alpha installer
  
Actual results:
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-kvm -S -M pc-0.11 -m 1024 -smp 1 -name rawhide -uuid 46a2dcee-09b2-73f8-160b-895511aa719c -monitor unix:/var/run/libvirt/qemu/rawhide.monitor,server,nowait -boot n -drive file=/mnt/d/img/rawhide.img,if=virtio,index=0,format= -net nic,macaddr=52:54:00:08:ee:00,vlan=0,model=virtio,name=virtio.0 -net tap,fd=22,vlan=0,name=tap.0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0 -k en-us -vga cirrus
char device redirected to /dev/pts/6
kvm_msix_add: kvm_get_irq_route_gsi failed: No space left on device
kvm_msix_update: kvm_update_routing_entry failed: Invalid argument

Then there is no qemu process running, virt-manager only displays information that can't access console.

Expected results:
Running installation.

Additional info:
I don't know, which space has left on which device, I have aprox. 3 GB free ram (virtual machine is defined to use 1 GB) and aprox. 800 MB free in /tmp and 26 GB free on partition where is my rawhide.img (qcow2 defined to use max. 8 GB).
Comment 1 Gene Czarcinski 2009-08-27 17:36:50 EDT
Same thing for me.  Even if I was installing F12 alpha, I specified Fedora 9 when creating the guest via virt-manager because DVD/CD iso image references are screwed up for if not IDE.
Comment 2 Mark McLoughlin 2009-09-04 08:54:04 EDT
(In reply to comment #0)

> kvm_msix_add: kvm_get_irq_route_gsi failed: No space left on device
> kvm_msix_update: kvm_update_routing_entry failed: Invalid argument

Okay, the issue here is that MSI-X support requires a newer kernel

We shouldn't exit on older kernels, though - this needs to be fixed
Comment 3 Mark McLoughlin 2009-09-07 03:04:44 EDT
Amit points this out as the likely fix:

  http://git.kernel.org/?p=virt/kvm/qemu-kvm.git;a=commitdiff;h=aca6915d92

This is building in dist-f12 now:

* Mon Sep  7 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.10.91-0.10.rc1
- Fix MSI-X error handling on older kernels (#519787)